Cannot create a new display

Forums / NoMachine for Windows / Cannot create a new display

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #37371
    SteveBooth
    Participant

    All of a sudden this morning, after running flawlessly for weeks, my NoMachine client stopped being able to connect to my Rocky 8 instance running inside a Google compute cloud VM. It shows:

    (screenshot)

    The bottom of the connection log has:

    —————————————————–

    NX> 105 Listsession --status="disconnected\054connected" --type="all" --shadowable="yes"
    NX> 149 Confirmation required for creating new frame buffer on server
    Startxserver --option="yes"
    NX> 500 ERROR: Cannot create a new display, please contact your system administrator.
    NX> 127 Session list of user 'steve':
    Display Type Session ID Services Depth Screensize Status Session name Username Platform Users Crea Node
    ------- ---- ---------- -------- ----- ---------- ------ ------------ -------- -------- ----- ---- ----
    NX> 147 Server capacity: reached for user: steve

    ——————————————————–

    I’m running Rocky 8 on my VM using KDE Plasma.  The DefaultDesktopCommand is:

    env -u WAYLAND_DISPLAY /usr/bin/dbus-launch --sh-syntax --exit-with-session /usr/bin/startplasma-x11

    I’ve spent the entire day, today, trying to figure out why NoMachine just randomly died.  Any help would be appreciated.

    SteveB

    #37418
    Britgirl
    Keymaster

    We’ve checked Rocky 8 and that the command is correct. Everything works fine for us and connect successfully. Did something change on the system such as an update or a new setting?

    Please submit the image that was missing. You can attach to another reply in this thread. Also a full set of logs from the server side would be useful. Please check here how to gather them: https://knowledgebase.nomachine.com/DT11R00182

    #37425
    SteveBooth
    Participant

    This has been resolved.  It was not a problem with NoMachine, but rather with the KDE Plasma runtime.  The LD_LIBRARY_PATH environment variable had been modified in the .bashrc script, so as to point to a slightly different version of QT5, which was incompatible with Plasma.  As a result, when the nxserver daemon tried to instantiate a new X-win environment, the request failed.  Took me a while to figure it out because the client-side error message had no indication that it was a server-side, Plasma problem.

    Thanks, though, for your help.  Appreciated.

    Steve

Viewing 3 posts - 1 through 3 (of 3 total)

This topic was marked as solved, you can't post.