Cannot detect any display running

Forums / NoMachine for Linux / Cannot detect any display running

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #26063
    AvatarKalabagh
    Participant

    Dear all,

    I think this is a recurrent issue, but after trying some staff read in this forums I decided to do a post. I have restarted the nxserver and disabled wayland but the issue does not disappear.

    In attached you can find the connection log. Any more information you need I will provide.

    Thanks in advance.

    #26089
    AvatarBritgirl
    Keymaster

    What OS and version is on the client? What Linux is it on the server side?

    The logs didn’t attach. I would send both client side and server side to forum[at]nomachine[dot]com.

    #26112
    AvatarKalabagh
    Participant

    Hi Britgirl,

    OS version in local is Ubuntu 17.10, client is NoMachine 6.9.2.

    Server side is an Amazon AMI, OpenSUSE Leap 42.1 x86-64

    Here are the logs:

    CONNECTION

    “NX> 164 Connection policy:

    Type                       Value
    ———————–    ——
    autocreate                  yes  
    autoconnect                 yes  
    automigrate                 yes  
    desktop                     no   
    dialog                      no   
    NX> 105 Resourcelist
    NX> 104 Lista de recursos :

    Class     Type                       Value
    ——— ————————– ——
    session   nxvfb                       no
    session   unix-console                no
    session   unix-gnome                  no
    session   vms                         no
    session   unix-remote-custom          no
    session   unix-xsession-default       no
    session   vnc                         no
    session   windows                     no
    session   unix-desktop                no
    session   unix-remote                 no
    session   unix-cde                    no
    session   shadow                      no
    session   unix-kde                    no
    session   unix-application            no
    session   unix-default                no
    session   unix-xdm                    no
    session   physical-desktop            no
    session   unix-script                 no
    service   server-printer-sharing      yes
    service   client-network-sharing      yes
    service   audio                       yes
    service   server-network-sharing      yes
    service   client-usb-sharing          yes
    service   server-disk-sharing         yes
    service   local-recording             yes
    service   client-smartcard-sharing    yes
    service   client-disk-sharing         yes
    service   client-printer-sharing      yes
    service   microphone                  yes
    service   server-file-transfer        yes
    service   client-file-transfer        yes
    service   session-recording           yes
    service   server-usb-sharing          yes
    feature   enable-multinode            no
    feature   client-clipboard            yes
    feature   manual-node-selection       yes
    feature   server-clipboard            yes
    feature   node-load-balancing         yes
    feature   bandwidth                   no
    node      localhost:4000              yes
    node      virtual-desktops-limit      no
    node      connections-limit           no
    NX> 105 Listsession –user=”cfd” –status=”disconnected\054connected” –geometry=”1920x1080x24+render” –type=”all” –reconnectable=”yes”
    NX> 149 Confirmation required for creating new frame buffer on server
    Startxserver –option=”yes”
    NX> 500 ERROR: No se puede crear una nueva pantalla. Por favor, contacte su administrador sistema.
    NX> 127 Session list of user ‘cfd’:

    Display Type Session ID Services Depth Screensize Status Session name Username Platform Users Crea Node
    ——- —- ———- ——– —– ———- —— ———— ——– ——– —– —- —-

    NX> 148 Server capacity: not reached for user: cfd
    NX> 105″

    SESSION

    “Info: Starting NoMachine version 6.9.2.
    Info: Loading settings from ‘.nx/config/player.cfg’.
    Info: Loaded translation files for ‘Spanish’.
    8529 8529 20:20:55 085,952 Main: Creating the client session.
    8529 8529 20:20:55 086,044 ClientSession: Initializing session at 0x136f8f0.
    8529 8529 20:20:55 238,862 ClientSession: Initialized session at 0x136f8f0.
    8529 8529 20:20:55 239,175 Main: Entering the GUI event loop.
    Info: Slave server running with pid 8555.
    Info: Listening to slave connections on port 37550.
    8529 8529 20:21:04 178,539 ClientSession: Starting session at 0x136f8f0.
    8529 8529 20:21:04 179,306 ClientSession: Going to start session ‘/home/ordenador/Documentos/NoMachine/Conexión a ec2-35-164-97-22.us-west-2.compute.amazonaws.com.nxs’.
    8529 8529 20:21:04 192,663 Connection: Initializing connection at 0x167dd10.
    8529 8529 20:21:04 192,863 Connection: Initialized connection at 0x167dd10.
    8529 8529 20:21:04 192,888 Connection: Starting connection at 0x167dd10.
    8529 8529 20:21:04 192,903 ClientDaemonConnector: Starting a new connection to host ‘ec2-35-164-97-22.us-west-2.compute.amazonaws.com’ on port ‘4000’.
    8529 8529 20:21:04 193,019 Connection: Started connection at 0x167dd10.
    8529 8529 20:21:04 198,808 ClientSession: Started session at 0x136f8f0.
    Info: Connection to 35.164.97.22 port 4000 started at 20:21:04 418,577.
    8529 8565 20:21:05 279,846 ClientSession: A valid certificate for this server was found.
    8529 8565 20:21:07 286,411 Connection: WARNING! Skipping a duplicate code 1000.
    8529 8529 20:21:07 501,816 ClientSession: Going to query the server for available services.
    8529 8529 20:21:09 533,254 Connection: Connection at 0x167dd10 failed.
    8529 8529 20:21:09 533,287 ClientSession: Runnable at 0x167dd10 caused the session at 0x136f8f0 to fail.
    8529 8529 20:21:09 533,300 ClientSession: Failing reason is ‘La negociación de la sesión falló.

    Error: No se puede crear una nueva pantalla’.
    8529 8529 20:21:09 540,614 ClientSession: Stopping session at 0x136f8f0.”

    SETTINGS

    nx/nx,cookie=A0B93010BD231BA656C8DFBDCC769A35,slave=65051,x11=0,id=localhost-65051-7CF546C1AB870DACB9B32F0B7F9A0576:65051″

    Many thanks.

    #26149
    AvatarMth
    Contributor

    Hello

    As this is Amazon virtual machine it is probably headless from the start, so there might be a few issues associated with this.

    Did you had to install Xserver and graphic environment manually or it came with it?
    If you did install it afterwards, are you sure it is running? If yes – here is the problem, that NoMachine did not recognize it.

    If no, the NoMachine will try to run the virtual session instead, but it need to be supplied with proper application path as to what to run.

    Please check the node.cfg file for key DefaultDesktopCommand and see what is there, and make sure it points to the desktop environment
    you installed. If it points to the generic Xsession script it may not be enough for operating system to run it.

    If there is a physical session running and we did not recognize it, we will require the server logs for debugging. Please also note that very rarely after
    installing the desktop environment the operating system requires restarting of NoMachine to be able to properly recognize the desktop.

    Article on how to collect logs:

    https://www.nomachine.com/DT10O00163 (“How to gather debug logs for support requests”)

    Please enable the debug and then do

    /etc/NX/nxserver --restart

    You can use the command

    /etc/NX/nxserver --debug --collect

    after the restart for NoMachine to automatically collect and pack the logs.

    Please send the logs to forum[at]nomachine[dot]com using the title of that forum’s thread as the mail’s subject.

    /Mth

    #26164
    AvatarKalabagh
    Participant

    Thank you for answering,

    I have to say that I have been working with the same Amazon AMI, with the same instance and configuration and with NoMachine since January and everything has worked properly. This happens to me only since a few days. So maybe is related with some update, but the only one I remember is related with the internet connection device.

    NX server came with it, I didn’t install it later.

    In DefaultDesktopCommand I can see: “dbus-launch –exit-with-session gnome-session –session=ubuntu”

    #26283
    AvatarKalabagh
    Participant

    Please, I need an answer.

    #26309
    AvatarMth
    Contributor

    Hello

    If it worked before the update- something may have changed in the system that we were not able to handle. And the most probable thing here is the
    update to gnome.

    My question remains though. Do you run a headless physical session or make NoMachine to run desktop on virtual session.

    If its the later, you probably need to update the DefaultDesktopCommand to what is right now used by the gnome.

    If you run:

    grep ^Exec /usr/share/xsessions/*.desktop

    command You will get how the system is running installed desktop environments.

    If you are running headless physical session, we need logs to check why it is not detected.

    /Mth

    #26341
    AvatarKalabagh
    Participant

    Good afternoon,

    That’s what I get when executing the command you said:

    “/usr/share/xsessions/ubuntu.desktop:Exec=env GNOME_SHELL_SESSION_MODE=ubuntu  gnome-session –session=ubuntu

    /usr/share/xsessions/ubuntu-xorg.desktop:Exec=env GNOME_SHELL_SESSION_MODE=ubuntu  gnome-session –session=ubuntu

    /usr/share/xsessions/unity.desktop:Exec=/usr/lib/gnome-session/run-systemd-session unity-session.target”

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.