Cannot detect any display running + nxnode is Disabled

Forums / NoMachine for Linux / Cannot detect any display running + nxnode is Disabled

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #36503
    fr2
    Participant

    Hi,
    I try from Xubuntu 20.04 to take remote control of another Xubuntu 20.04
    On both I use NoMachine 7.7.4_1
    But have this error :
    “Cannot detect any display running. Do you want NoMachine to create a new display”
    I say yes and have (translation of French):
    “Unable to create new display. Please contact your administrator”
    But I’m the administrator ^^

    On the server side I active collect log, I join here

    I notice that nxnode is set to “Disabled” on server side but don’t understand why

    $ sudo /etc/NX/nxserver --restart
    NX> 162 Disabled service: nxserver.
    NX> 162 Service: nxnode already disabled.
    NX> 162 Disabled service: nxd.
    NX> 111 New connections to NoMachine server are enabled.
    NX> 161 Enabled service: nxserver.
    NX> 162 Disabled service: nxnode.
    NX> 161 Enabled service: nxd.

    I joined my NoMachine-log.tar.gz (server)

    Problem have started with lag and i try to manually upgrade my server & client.
    I try many things : revert to version 6 etc but nothing work 🙁

    #36625
    Britgirl
    Keymaster

    What’s the desktop environment/window manager that you have installed there?

    We would need to see the .nx directory from the user’s home on the server side. Please attach it here or send directly to forum[at]nomachine[com].

    #36653
    pmanousos
    Participant

    Greetings.   We are testing use of  NoMachine (NM) and on the host side we run v 7.6.2 on a headless RHEL 7 OS server.  On the client side we run NM for Windows (Win 10 Enterprise laptop).

    On the host side, it is required for X to be running in the background to support image processing.   We have Gnome Desktop Manager started upon boot –  this triggers X :0 to be running in the background and also allows NM to render a desktop to the client side.

    However, we notice the action of logging out of a remote session via NM, kills the X server background job that was originally started at boot, and replaces it with a  new X server process running in the background.     This negatively impacts other jobs that were running and using the resources from the original X server process.

    Is there a way to configure NX on the server side to not kill an X server process upon logout?  We dont believe there is a way to do so after reading through the docs and forums, but wanted to get confirmation as such.

     

    #36678
    fr2
    Participant

    Resolve with force delete all nx folders and reinstall NoMachine

    #36689
    Britgirl
    Keymaster

    @pmanousos NoMachine Terminal Server for Linux is what you need. The functionality of disconnecting (suspending) is possible with NoMachine Terminal Server family. You could start with Workstation, this product will let you create up to 4 NoMachine virtual desktops which can be left running in the background. Users will be able to reconnect to them.

    On Linux, when connecting to the physical desktop which doesn’t have an X server running (e.g. it’s a headless machine), NoMachine is able to use its own display service (that is an embedded X server) to let users connect seamlessly to a physical desktop running in the background on the remote machine. This ability is enabled by default in NoMachine free version, but can be activated also for the other server types.

    Please see this article in our Knowledge Base:
    https://knowledgebase.nomachine.com/AR10K00700

    #36690
    Britgirl
    Keymaster

    @fr2, ok thanks for letting us know 🙂

Viewing 6 posts - 1 through 6 (of 6 total)

This topic was marked as solved, you can't post.