“Cannot find X servers running on this machine” on bspwm session

Forums / NoMachine for Linux / “Cannot find X servers running on this machine” on bspwm session

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #36887
    VerdeQuar
    Participant

    Hi. I’m trying to use NoMachine to screenshare to my friend (without remote control, just screensharing) and everything worked great but recently I moved over from plasma to bspwm and it seems X server isn’t being detected correctly there.
    Some time earlier I was on plasma with KDEWM env var set to bspwm and it worked fine. The problem shows when using plain bspwm session.

    I’ve included my xsession files as well as NoMachine logs from plasma-bspwm session and plain bspwm session.

    OS: Manjaro Linux x86_64

    Kernel: 5.14.21-2-MANJARO

    CPU: AMD Ryzen 5 3600 (12) @ 3.600GHz

    GPU: AMD ATI Radeon RX 5600 OEM/5600 XT / 5700/5700 XT

    bspwm version: 0.9.10

    Plasma version (when using plasma-bspwm session): 5.23.4

    NoMachine version: 7.7.4

    #36893
    VerdeQuar
    Participant

    Ok I got it working, turns out when I run bspwm through sddm (or display manager in general, I didn’t test other dm) it doesn’t work, but when I configured xinitrc and run it through startx it works fine.
    I’ve included logs from when I start using startx

    #36907
    Britgirl
    Keymaster

    Thanks for updating the topic. We did actually have a look at this problem in our labs and weren’t able to start bspwm from GDM without NoMachine involved, so it seems to be a problem with bspwm, not NoMachine.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.