Cannot get SSH to work

Forums / NoMachine for Raspberry Pi / Cannot get SSH to work

This topic contains 2 replies, has 2 voices, and was last updated by Avatar KOREFUJI 1 year, 11 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #16464
    Avatar
    KOREFUJI
    Participant

    I am new to this software from NoMachine, previously a synergy user, but after the fiasco of synergy 2.0 I’m looking to move away to something back to basics. NoMachine seems to fit the bill, but I can’t seem to get it working.

    I have a Windows machine with NoMachine installed. I have a raspbian install on a pi3 with NoMachine installed on that too. The service has been started and is working. I can connect via NX, but not via SSH.

    I am able to connect via SSH using XShell software, and have been configuring and installing things that way. The desktop environment is installed on the headless  pi3, but to no avail. I still get a timeout error. Error 138.

    I’ve ensured firewall access is allowed, on both devices, both pi3 and Windows 10 pro pc.

    If the software works as both client and server, then it shoudl just work, but not having any luck. Can get synergy to work fine (1.x not 2.x as the latter is a nightmare with no interface).

    Hopefully someone here can help. I’ve looked at a few of the other threads.

    Both pi3 and Windows 10 pro pc are using a wired ethernet connection. I am able to ping the pi3, and ssh with other software, sftp to it too, but not with NoMachine. Not sure what is blocking it.

    Please advise. Thanks.
    NB: All version are free and up to date it seems. I am using ARM6hf on the pi3, and Windows free version. All this is local. I can connect to the pi3 remotely using the web via Dataplicity software. It’s an online cmdline software. Pi3 is on latest Raspbian Stretch. Pi3 is not connected to a monitor, hence a headless machine.

    Windows 10 is connected to a 4k monitor.

    #16489
    Avatar
    Britgirl
    Keymaster

    The free product does not support SSH protocol. Features available in the free version are highlighted here: https://www.nomachine.com/nomachine-features.

    But you should be seeing a message like this when you try to connect to the Pi “Running NoMachine sessions over a SSH is not supported” or similar,¬† not an Error 138.

    To understand better why you’re not seeing the message logs would be useful. You can follow the instructions here (https://www.nomachine.com/DT07M00098) and send them to forum[at]nomachine[dot]com.

    #16490
    Avatar
    KOREFUJI
    Participant

    Thanks for the reply.

    I understand now that SSH is not supported in the free product. It’s a real shame, but SSH is very important for me, so I’ll be going back to Synergy 1.8 until they fix 2.0.

    With regards to Error 138, I believe that was a permissions issue where the remote machine did not have a writeable directory for the user that was logging in.
    Thanks all the same.

Viewing 3 posts - 1 through 3 (of 3 total)

This topic was marked as solved, you can't post.