Cannot grab special keys after upgrading to Ubuntu 20.04

Forums / NoMachine for Linux / Cannot grab special keys after upgrading to Ubuntu 20.04

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #31998
    ConflictKar
    Participant

    Hello everyone,

    After upgrade from Ubuntu 18.04 to Ubuntu 20.04 with dist upgrade command I’ve been having issues passing special keys to my remote desktop, which runs on Ubuntu 18.04. For example pressing super key launches gnome startup menu on client (local) rather on host. Pressing alt+tab rotates running applications on client. Before upgrading grabing keyboard input worked fine (after ticking checkbox ‘grab keyboard input’).

    I also connect to the same remote desktop using a win10 pc and special keys are passing through.

    I’ve been using NoMachine for almost 2 years and I never had an issue passing special keys to remote desktop. Could it be some config that reseted after the upgrade? Or is it something more serious?

    #32015
    Tor
    Contributor

    Hi. Please try to start the player with the --activegrab option, by running the command

    /usr/NX/bin/nxplayer --activegrab

    If it helps you can either create a link to the player to always add that option, or you can edit the file $HOME/.nx/config/player.cfg and set the configuration key “Enable active keyboard grabbing” to “true”.

    #32023
    ConflictKar
    Participant

    Hi there,

    I have already tried using the --activegrab argument but it didn’t help.

    Is there anything else I could try?

    #32358
    Britgirl
    Keymaster

    Hi, we have a Trouble Report currently open for Wayland:

    Grabbing the keyboard doesn’t work when Wayland is enabled
    https://www.nomachine.com/TR10P08952

     

    Can you check that Wayland is disabled/enabled?

    echo $XDG_SESSION_TYPE

    uncomment or set:

    WaylandEnable=false in the:/etc/gdm3/custom.conf

    and reboot. Does this help?

    #32363
    ConflictKar
    Participant

    Hello, I confirm that the problem had to do with Wayland.

    Turning it off solved the problem for me.

    Thank you very much for your help!

Viewing 5 posts - 1 through 5 (of 5 total)

This topic was marked as solved, you can't post.