Cannot open a virtual desktop

Forums / NoMachine for Linux / Cannot open a virtual desktop

This topic contains 5 replies, has 3 voices, and was last updated by Avatar Cato 1 week, 4 days ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #23448
    Avatar
    cngc
    Participant

    I am getting the error when attempting to connect to a RHEL 6.X server from a Windows 10 client. This is a small domain with no internet access. The error that appears is “The Session negotiation Failed. Error: Cannot create directory /SHAREDRIVE/PATH/USERFOLDER.” It seems some account (Possibly the nx account) is attempting to write to the share drive. I did a complete uninstall of the previous NX Server and freshly installed NX 6. Any guidance on what could be going wrong would be greatly beneficial.

    I am unable to bring the logs off the system but can search for information.

    #23454
    Avatar
    og00r
    Contributor

    Did you check that full path to directory which returns error exists, got correct permissions and correct owner is set for directory and parents directory? Could you paste which directory cannot be created?

    #23467
    Avatar
    cngc
    Participant

    I did check that the folder had open permissions set to it. I wasnt sure who would be the correct owner. It is writing to the Users home folders that are located on a share drive. I cannot copy and paste unfortunately as it is a stand alone network. The exact location is a Share Drive /usr1/people/Adm_XXX(my user account)/.nx/M-severname-#####-XXXXXXXXXXXXXXX. I creates the last folder but, its empty. I cant tell if the nx user account is trying to create the folder or if it is my user account.

    #23488
    Avatar
    og00r
    Contributor

    Creating M-servername-xxxx directory won’t help in this case, this directory is dynamically by nxnode for each session. You should check if user Adm_XXX (I assume that you are trying create session for him) has correct access (permissions) to /usr1/, /usr1/people/ and /usr1/people/Adm_XXX

    If you think that there everything is ok, but it still won’t work you can redirect place where that directory is created by editing node.cfg. Default path should be /usr/NX/etc/node.cfg on remote machine. There is key #UserNXDirectoryPath which points where directory should be created. You must uncomment it and provide path which exist and users have access. There is good example in key description in config file.

    #23535
    Avatar
    cngc
    Participant

    So the permissions look as right as I can understand them. They do however have a 10-digit username and group (I.E. instead of root : root it displays a string of numbers like 1111111111 : 1111111111) which I cannot identify.

    I created a local user account and I was able to open the NoMachine desktop and login with that local user account just fine. That local user directory is /home/testnx.

    I was going to change the User NX directory path but, I believe that will not solve the issue without creating other issues. We are using a LDAP server for authentication as well as this being a Windows Domain using AD connected through a LDAP to the two NX servers.

    #23549
    Avatar
    Cato
    Contributor

    Hello cngc,

    may you please answer to the following questions?

    1) Do you use dynamic mounting of user’s home directory?

    2) If yes, can you share some details about your configuration?

    3) Do you use pam_mount or perhaps AFS?

    4) Does the problem occur when SELinux is disabled?

    5) Does the problem occur when you’are physically logged-in on the account of the problematic user on server host?

    6) To rule out possible problems with domain accounts binding, please execute in a terminal on the server host:

    id <user_name>

    Does it correctly report local ID for user, user’s primary group and all supplementary groups of user, including domain groups?

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.