Cannot open session: WARNING! Failed to open display ‘:1024’

Forums / NoMachine for Linux / Cannot open session: WARNING! Failed to open display ‘:1024’

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #26318
    AvatarLis Witalis
    Participant
    Dear Support,
    please help me solving this problem. NoMachine used to work perfectly fine for me, however I have not been using it for some time. Now I cannot open session, authentication succeeds but I only see a white blank screen.
    Both server and client are Ubuntu 18.04, the server has recently been protected with ‘pbis-open’. I am connected over VPN (Cisco Any connect). Server & client v. 6.9.2.
    Server side logs:
    nxerror.log:
    26398 26480 11:35:57 544.930 ServerNetworkInfoHandler: WARNING! Obtaining network data failed.
    Info: Handler started with pid 26538 on Fri Mar 27 11:37:47 2020.
    Info: Handling connection from 192.168.160.127 port 54748 on Fri Mar 27 11:37:47 2020.
    No protocol specified
    No protocol specified
    26398 26564 11:37:54 530.590 HostWmRunningHelper: WARNING! Failed to open display ‘:1024’.
    nxserver.log:
    2020-03-27 11:15:32 879.516 25900 NXSERVER User ‘piotr’ logged in from ‘192.168.160.127’ using authentication method NX-password.
    2020-03-27 11:15:33 133.945 25785 NXSERVER WARNING! Cannot check WM on display :1024 ENOENT
    node/C-xxxxxxxx/session
    Session: Starting session at Fri Mar 27 11:35:51 2020.
    Info: Agent running with pid 26467.
    Info: Slave server running with pid 26486.
    Info: Display running with pid 26487.
    Info: Listening to slave connections on port 12001.
    Info: Audio server started with pid 26494.
    Info: Audio client started with pid 26495.
    Info: Display server started with pid 26496.
    X Error:  147
      Request Major code 140 ()
      Request Minor code 9
      Error Serial #12
    26467 26467 11:35:51 093.042 restoreGamma: WARNING! Failed to get output info.
    Session: Session started at Fri Mar 27 11:35:51 2020.
    26467 26487 11:37:55 062.803 DrmGrabber: ERROR! DRM init failed.
    26467 26487 11:37:55 062.829 WaylandPoller: Init failed.
    26467 26487 11:37:55 063.217 WaylandPoller: WARNING! Failed to restore screen info without having DBus connection.
    nxagentShadowInit: ERROR! Failed to initialize the shadow display.
    Info: Display server for 576595780054597F4D567278899F882B connected on Fri Mar 27 11:37:55 2020.
    Info: Audio server for 576595780054597F4D567278899F882B connected on Fri Mar 27 11:37:55 2020.
    Info: Audio client for 576595780054597F4D567278899F882B connected on Fri Mar 27 11:37:55 2020.
    NXShadowEvent: WARNING! Shadowing not initialized.
    Thank you, best regards
    Lis Witalis
    #26368
    Avatargraywolf
    Moderator

    Hello. Is that a virtual machine? Or is the NVIDIA proprietary driver installed?

    #26381
    AvatarLis Witalis
    Participant

    Dear Support,

    On the server side Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor Graphics Controller (rev 09) is installed, with no proprietary drivers.
    On the client side I have an Intel graphics with no proprietary drivers.
    Both are running on bare hardware.
    Thanks
    Lis

    #26393
    Avatargraywolf
    Moderator

    May I ask you to reproduce using a debug library, gathering server logs and send to forum (at) nomachine (dot) com ?

    #26423
    AvatarLis Witalis
    Participant

    Sure, please provide me with the library.
    Regards
    List

    #26510
    Avatargraywolf
    Moderator

    From the logs it fails at an early stage. Is any monitor attached to the video output of the server? Or is it run headless?

Viewing 6 posts - 1 through 6 (of 6 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.