Cannot Share Virtual Session with NoMachine Workstation

Forums / NoMachine Terminal Server Products / Cannot Share Virtual Session with NoMachine Workstation

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #5257
    veloh
    Participant

    I am attempting to share a virtual session between two remote users using an evaluation version of NoMachine Workstation 4.3.30 running on Ubuntu 12.04.

    When multiple users connect to the same virtual desktop session, the first user can create the session, but as soon as the second user connects, the first user is disconnected.  This is the same problem that was described here.  Following the instructions in the thread, I have modified server.cfg to include the line:

    ConnectPolicy autocreate=0,autoconnect=0,automigrate=0,desktop=0

    As per the earlier thread, setting ConnectPolicy/automigrate=0 does not change this behaviour.  I do not believe that the problem is a lack of connections, because two users can successfully connect to different virtual sessions.  The problem also does not seem to be that no sessions can be shared, because two users can successfully share the Physical display.

    We would like to share a virtual session because we would like to use this for remote pair programming, involving a lot of text, and sharing with the new codecs is simply too blurry, especially when the screen changes rapidly (scrolling) or the machine is loaded (compiling).

    Any assistance would be greatly appreciated.

     

    #5262
    reza
    Moderator

    Regarding disabling automigrate option we have a Trouble Report:

    https://www.nomachine.com/TR10L04611

    Are you using the same user account to create a new virtual session and share it (second connection)?

    If yes please try to use separate user accounts.

    #5265
    veloh
    Participant

    Thanks Reza.  So I was using the same user account to both create and share.  When I use a second account to share, both sessions are allowed to connect, which is great.

    However, only the first session uses the lightweight protocol – the second session uses VP8.

    Is there a way to force both sessions to use lightweight?

    #5277
    Bilbotine
    Keymaster

    Hi veloh,

    No, there is no way to have lightweight in both sessions.

Viewing 4 posts - 1 through 4 (of 4 total)

This topic was marked as solved, you can't post.