Cannot shut down service

Forums / NoMachine for Mac / Cannot shut down service

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #39533
    jb
    Participant

    Not sure if this is similar to https://forums.nomachine.com/topic/server-settings-for-authentication-fails-for-domain-users#post-38601  My Mac is enrolled on a domain, but able to work away from the work network – I can’t shut down the NoMachine service.

    I really don’t want to run a server on my laptop, so would like to disable this feature permanently. I’ve tried the solution given in the thread (selecting don’t open at startup), but that didn’t work. (see attachments)

    I do have sudo access, so can perform administrative roles, but nxexec is not registering that my account has admin rights.

    Any ideas on how to solve this? Is there a startup file that can be edited etc?

    Best wishes, Jon

    #39545
    Britgirl
    Keymaster

    Hi,

    can you tell us the macOS version you are connecting from and the distro of the Linux server that you are connecting to (you mentioned it in a duplicate topic you submitted), just so we have all the details?

    In the meantime, on the Mac machine you can disable the nxserver from the command line.

    On Mac:

    sudo /etc/NX/nxserver --shutdown
    
    sudo /etc/NX/nxserver --startmode manual

     

    Check this article for further details. It also describes the manual procedure (by editing /Library/LaunchDaemons/com.nomachine.server.plist file) for advanced users.

    https://kb.nomachine.com/AR04L00800

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.