Cannot successfully open session

Forums / NoMachine Terminal Server Products / Cannot successfully open session

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #19856
    AvatarStMartin81
    Participant

    Hello,

    I’m evaluating the NoMachine Workstation and I’m not able to successfully establish a connection. When I have started a physical session on the server it is not listed in the player. When I try to start a new virtual session all I can see is a spinning circle while the player tries to create a connection to a new virtual session. Is it possible that some needed ports are blocked by our company firewall?

    Error in nxwebclient.log:

    NXWEBCLIENT: Socket::openConnection Connection to port 38328 failed with error number 111: Connection refused

    Output from /etc/NX/nxserver –version:
    NoMachine Workstation Evaluation – Version 6.2.4
    Output from /etc/NX/nxserver –list:

    NX> 127 Available sessions:

    Display Username Remote IP   Session ID                       Node
    ——- ——– ———– ——————————– ————–
    sto      10.30.8.201 E010064C81772E69F6B9FCF30282DE77 localhost:4000

     

    Output from /etc/NX/nxserver –history:

    Display Username Remote IP   Session ID                       Date                Status   Node           Type
    ——- ——– ———– ——————————– ——————- ——– ————– ————–
    sto      10.30.8.201 E010064C81772E69F6B9FCF30282DE77 2018-10-08 12:20:20 Starting localhost:4000 unix-xdm
    sto      10.30.8.201 D12E48359230ED31A1F2781FDD133C69 2018-10-08 12:19:40 Failed   localhost:4000 unix-kde
    sto      10.30.8.201 F67159E4F481ACB9704EE57073096389 2018-10-08 12:19:40 Failed   localhost:4000 unix-gnome
    sto      10.30.8.201 63E7FFB52D1EE3F6F974F0180F8E9A97 2018-10-08 12:18:36 Failed   localhost:4000 unix-console

    #19860
    AvatarBritgirl
    Keymaster

    The attachments were perhaps too big and so were refused. Could you send them to forum[@]nomachine[@]com. Thanks!

    #19882
    AvatarStMartin81
    Participant

    Next try uploading configuration.

    #19931
    AvatarShoti
    Contributor

    Hi StMartin81,

    We can’t reproduce problem in our labs. To investigate this issue further, we would need the logs from server side. Please find the instructions here: https://www.nomachine.com/DT10O00163. You can send them to forum[at]nomachine[dot]com

    #20070
    AvatarAMSCAE
    Participant

    Maybe this feature request is going to solve your problem regarding physical connection:

    Extending access to physical desktop to unprivileged users with Linux Terminal Server products

    https://www.nomachine.com/FR10P03717

    You can get notified when this feature gets implemented by ticking the box.

    #20077
    Avatarbrotech
    Participant

    Hello StMartin81,

    please enable logs for nxserver, nxnode and also nxwebplayer. You can do that using
    one command:

    sudo /etc/NX/nxserver –debug –enable all

    Then restart nxserver(sudo /etc/NX/nxserver –restart), reproduce problem, collect logs
    and please send again. In last logs there are only debug messages from server.

    If the physical session is available, it will be on the list for administrators or trusted users only, until
    FR mentioned by AMSCAE will be implemented and released.

    #20090
    AvatarCato
    Contributor

    Hello StMartin81,

    Logs indicate that you’re using pam_mount module to mount user’s home directory.
    Please, check this article explaining how to solve issues related to NoMachine and pam_mount:

    https://www.nomachine.com/AR09N00902&an=pam_mount

    Let us know if this solves the problem.

    #20098
    AvatarStMartin81
    Participant

    Yes, you are right. I had a .pam_mount.conf.xml file in my home directory. Thank you!

Viewing 8 posts - 1 through 8 (of 8 total)

This topic was marked as solved, you can't post.