Can’t access from internet with UPnP enabled

Forums / NoMachine for Linux / Can’t access from internet with UPnP enabled

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #36487
    sysosus
    Participant

    I’m trying to connect from internet with NoMachine.
    The server is installed on Ubuntu 20.04
    I’ve enabled UPnP in /usr/NX/etc/server.cfg. I’ve also done it on my router and also done a manual port forwarding to the local port 4000 with both TCP and UDP.
    Nothing seems to work

    When I execute “./nxserver --upnpstatus” i get “Gateway: 0.0.0.0” and “--upnpmap” didn’t fix a thing
    Also tried to manually change gateway port from GUI but it says to me “Failed to map the port on the gateway”

    What else can i do?

    #36511
    Britgirl
    Keymaster

    Hi, did you already follow the instructions here?

    How to connect over the internet to NoMachine behind a NAT router
    https://knowledgebase.nomachine.com/AR10R01099

    #36518
    Britgirl
    Keymaster

    Can you also tell me the following?

    – the router model
    – what the exact full output of --upnpstatus and --upnpmap is when you execute those commands?
    – which NoMachine product you have installed on the computer you are connecting to?

    #36519
    sysosus
    Participant

    I finally solved. I don’t know why, I shouldn’t wonder why but my router (fritzbox) refuses to open the port 4000.

    Only that port.

    i just tried with another port and changed the server.cfg file and it works.

    I… I’m not gonna ask why…

    #36530
    Britgirl
    Keymaster

    Thanks for letting us know, but we would still like to investigate some more, if you are available 🙂 in order to make sure that NoMachine is working correctly and to see what improvements could be made. For example, improving printed messages to inform the user.

    What we would need ideally is the debug logs from the server-side.

    1. In a console, enable nxserver debug (you check for detailed instructions for your OS here: https://knowledgebase.nomachine.com/DT11R00182)

    # /etc/NX/nxserver –enable server –debug
    NX> 900 Debug mode enabled for: server

    2. Restart nxserver:

    # /etc/NX/nxserver –restart

    3. Fetch upnp status:

    # /etc/NX/nxserver –upnpstatus

    4. If no port mapping is shown, please start port mapping by hand:

    # /etc/NX/nxserver –upnpmap

    After which you should gather the logs and send to us at forum[at]nomachine[dot]com.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.