Can’t connect from internet, get error 51

Forums / NoMachine for Linux / Can’t connect from internet, get error 51

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #34060
    Avatargingerlilys
    Participant

    Hello,

    I  try to use NoMachine free to connect to my machine from the internet. It works pretty well on local network, even when I connect through the public IP/port combo. However it doesn’t work as soon as I am outside of the local network, on the internet: I get error 51.

    My machine is on Ubuntu 20.04, ethernet with CPL connection to an ISP router with UPNP enabled. I can see the rule generated to forward public 23868 to local machine 4000.

    I have also manually opened 23868 on the router, but it doesn’t change anything. I have tried different things found on this page https://knowledgebase.nomachine.com/AR11L00827 but nothing works.

    Please could you help me ?

    Regards.

    server: Ubuntu 20.04.2, Gnome 3.36.8, NoMachine free 7.6.2

    client: iPad air 4, iPadOS 14.6, don’t know where to find version number of NoMachine client

    router: bbox Fast5330b-r1, UPNP enabled, connection to machine over CPL

    #34083
    AvatarBritgirl
    Keymaster

    You have a double nat maybe? Check this topic: https://forums.nomachine.com/topic/router-on-double-nat-cant-get-external-ip-for-remote-connections

    My last comment in particular in that topic was “UPnP doesn’t support the double NAT scenario, you would need to enable port-forwarding on both routers.” Have you tried that?

Viewing 2 posts - 1 through 2 (of 2 total)

This topic was marked as solved, you can't post.