Can’t connect outside of local network

Forums / General Discussions / Can’t connect outside of local network

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #2110
    Avatarkimdvm
    Participant

    NoMachine – free, Linux Mint 13 (Maya) -local/server, Windows 8

    I’m trying to connect to a linux machine from a windows laptop.  The software is installed on both machines and the server is running on the linux machine.  When I look at the forwarded ports screen it gives a private ip as the gateway ip (192.168.99.198).  I can connect when I’m on the network by entering this ip but not, as one would suspect, when I’m on a different network.  I’ve tried to set up port forwarding on the router but so far it is not working – the gateway ip continues to be displayed as the private ip and entering the public ip returns a connection refused error.  My routing table shows 192.168.99.198 as a gateway ip so I’m not really sure how to make it work.  I’m also wondering if the public ip changes, how is nomachine able to find and connect to that machine?

    #2121
    Avatarreza
    Moderator

    We didn’t publish all the information on your routing table, but from it we can see that you have a double NAT. So NoMachine has to go through two. That is, a router facing the internet for which you have a private LAN with IP address of 192.xxx.xx.x) and then another router  for access to the private network/LAN for which you have an IP address of 192.xxx.x.x).

    UPnP doesn’t easily support this type of scenario. In this particular case, our upcoming product NoMachine Anywhere would resolve this problem for you and the hassle of having to configure routers by hand or setting up awkward tunnels.

    Until then, and if you have access to both your routers, port forwarding should be set up on the second one as you already did for the other that you mentioned.

    • This reply was modified 6 years, 11 months ago by Avatarreza.
    #2144
    Avatarkimdvm
    Participant

    Thanks for your reply.  I want to make sure I’m doing the correct thing.  Here is my set-up.

    DSL Modem (Netgear DM111P) – VOIP Adapter – Router (Cisco/Linksys WRT 160N).  So I need to set up port forwarding on the modem as well?  Am I setting the port forwarding the same for the modem or do I need to forward the modem to the gateway ip and then forward the router to the private ip?

     

     

    #2247
    AvatarBritgirl
    Keymaster

    If the modem doesn’t work in ‘bridge’ mode but you have NAT on both modem and router then yes, you will have to set forwarding on both.

Viewing 4 posts - 1 through 4 (of 4 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.