Can’t connect reliably from Windows to headless Linux

Forums / NoMachine for Linux / Can’t connect reliably from Windows to headless Linux

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #40266
    cole
    Participant

    Hello,

    I have been using NoMachine for a few years on my headless server. After updating to NoMachine version 8, I am having a lot of trouble maintaining a remote desktop connection. My server is running Ubuntu 20.04.5 LTS. My server is on a different network so I am connecting from a different network 100% of the time.

    The first issue I ran into after updating was UPnP port forwarding turned off automatically. I added permanent port forwarding entry to my router so this doesn’t happen again. After a random amount of time, the remote desktop will freeze and then I will be logged out to the lockscreen. I will type in my password and the screen will go black and I will then be at the lockscreen again. I am unable to log in at this point.

    I close the remote desktop window and try to start the connection again. the connection window asks for my system username and password. I enter my user and pass but it says authentication failed (i am typing my password correctly). If I click “reset saved preferences and password” it will now allow me to connect to my server again. Occasionally it will not recover and the remote desktop window will say “no available desktops on this server”. After 30 minutes i am able to connect again.

    This connection problem is present on the free Enterprise Client on Windows 10 and Fedora 36 connecting to my Ubuntu server.

    I do not understand why the remote desktop is freezing/logging out. I am the only one connecting to this server so I disabled all the guest settings. I do not know which logs i need to share to help diagnose this

    What to include info:
    remote machine is using version 8.0.168 free, local is using Enterprise Client free version 8.0.168
    the remote machine doesn’t have a physical monitor plugged into it, so i think it’s a virtual display
    remote machine Ubuntu 20.04.5 Gnome desktop version 3.36.8 x11, local Windows 10 21H2 19044.2006

    #40293
    Britgirl
    Keymaster

    Hi cole,

    this is certainly strange behaviour and would need further investigation.

    Could you please provide the following?

    1) NoMachine server side logs (see the document here for complete instructions, https://kb.nomachine.com/DT07S00243)

    2) the file /etc/X11/Xorg.0.log.old  if its present

    3) output of 'sudo journalctl -b'

    4) any core files after debugging with https://kb.nomachine.com/AR09L00810

    You can send all this information directly to forum[at]nomachine[dot]com. Please use the title of this title of this topic as the subject of your email.

    Edited 23/9

    The first issue I ran into after updating was UPnP port forwarding turned off automatically. I added permanent port forwarding entry to my router so this doesn’t happen again.

    From this release UPnP/NAT-PMP is disabled by default in the Free Edition. You can either enabled port-mapping or as you did fix a rule on the router.

    This information was omitted from the software update announcement and we apologize for that. It’s since been updated.
    “To get access to your computer from outside your private network, NoMachine’s UPnP/NAT-PMP port mapping must be enabled by hand (‘Server settings -> Ports’), or alternatively your router can be configured with the appropriate port-forwarding rule. When port-mapping/port-forwarding is enabled, remote NoMachine connections, including connection requests from guests via the new Guest Desktop Sharing feature, will be possible. ”

    https://kb.nomachine.com/SU09T00237

    #40356
    Britgirl
    Keymaster

    We received the output and logs that we requested. Thanks for those.
    From that we can see there is a crash of Xorg and looks similar to an issue we saw on version 7 which was related to how X server “goes offscreen”, not caused by the NoMachine software itself.

    Just to make sure it indeed is that, can you try disabling the blanking of the screen on the Ubuntu server?
    open the NoMachine UI on the remote host -> Settings -> Server -> Security and uncheck the ‘Blank the physical screen when somebody connects’ option.

    Also, we see that you have lock screen at disconnection disabled. Confirm that indeed it is (it’s in the same Security panel as above).

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.