Can’t connect thru internet

Forums / NoMachine for Mac / Can’t connect thru internet

Viewing 15 posts - 1 through 15 (of 16 total)
  • Author
    Posts
  • #41282
    Fritz
    Participant

    NM v8.1.2 free

    Wifi connect was instantaneous, but can’t seem to get connect thru internet.

    Coming from High Sierra [10.13.6] MBA to Big Sur [11.7.1] Intel mini.

    Both are Port 4000 NX protocol.  Set a PF on the router.

    Error: no route to the network or host 192…..was found.  Issue could be wrong server ADR or network problem.

    Should I be using the WAN instead of the LAN IP or ….?

    The ADR that comes up in NM Setting is the LAN of the router, not the public IP.

    #41356
    Britgirl
    Keymaster

    Hello,

    to be able to connect from outside your LAN, you need to use the public IP address of the computer you want to access. Please check the following articles if you have not already done so:

    How to connect over the Internet (enable UPnP to automatically configure port mapping)
    https://kb.nomachine.com/AR10T01175

    How to connect over the internet to NoMachine behind a NAT router
    https://kb.nomachine.com/AR04S01122

    You can also check your External IP, for example, on whatismyip.com.

    If this doesn’t help, please send a screenshot of the message you are receiving.

    #41368
    Fritz
    Participant

    Realized after a fashion that I needed to use the PIP.

    But perhaps that and/or the link should be in the built in help screen.

    Working so far though

    #41371
    Britgirl
    Keymaster

    By PIP I suppose you mean “public” IP address? If so, then, it can be that your router doesn’t support UPnP. Or that our UPnP doesn’t support your router :-). Anyway this shouldn’t affect your ability to connect, even from the outside.

    Please check my response to a similar post here: https://forums.nomachine.com/topic/are-my-settings-for-connecting-over-the-internet-ok#post-39243

    Maybe you didn’t already see our online tutorial which is specifically for users connecting over the Internet.

    https://www.nomachine.com/getting-started-with-nomachine#internet

    You can also find a variety of other useful tutorials in our support section here:

    https://www.nomachine.com/all-documents

    #41389
    Fritz
    Participant

    I cannot toggle any of these settings.

    Previously, the server wouldn’t launch.
    I uninstalled/re-installed and the server works.  But can’t toggle.

    Big Sur 11.7.1

    #41400
    Britgirl
    Keymaster

    Unforunately, whatever image you pasted didn’t upload so we can’t see what settings you can’t toggle. Please use the attachment utility to include any screenshots in your follow-up. (i.e no pasting of images). Thanks.

    #41414
    Fritz
    Participant

    attached … I hope.

    #41565
    Britgirl
    Keymaster

    I cannot toggle any of these settings.

    What happens if you click the ‘Desktop shared’ button? What happens if you click ‘Restart/stop/shutdown the server’? Is this happening on your  High Sierra or Big Sur?

    #41593
    Fritz
    Participant

    Big Sur.

    I can toggle desktop shared.  But nothing else changes or toggles.

    #41597
    Britgirl
    Keymaster

    The “Desktop shared” label in the Server status (your image) is static, so it’s not possible to toggle “Desktop shared” there. You can toggle it either from the system tray menu or in the UI at the bottom on the right (see the the two images here: https://kb.nomachine.com/DT07S00239#4.1 and https://kb.nomachine.com/DT07S00239#4.3). Can you toggle it from these two places?

    Can you show us a short video which shows where you are clicking and what you are not able to interact with? Or a sequence of screenshots which show us the steps you are following?

     

    #41644
    Britgirl
    Keymaster

    So looking at the video you made available to us (thanks by the way).

    When clicking those items (Restart server, shut down etc) you should see an authentication request dialog. This request is executed by a nxexec process checking credentials. For some reason this dialog is not appearing. Can you check whether clicking the link “Changes disabled” (bottom left)  does nothing as well?

    If nothing happens when clicking on that link, we would need to check client and nxexec logs from the affected machine.

    For logs on macOS, please consult: https://kb.nomachine.com/DT11R00182. Enable logs, try to reproduce the problem and then gather the logs up. Send via email as you did before. Thanks!

    #41645
    Fritz
    Participant

    Changes disabled – nothing

    Quit NoMa – from the menu bar – nothing.

    FWIW my pIP doesn’t show in the Main Window  – UPnP is checked in the router.  This doesn’t matter as I can always look up if  ddns fails or something screwy happens.

    Main Window and Service status are they same window?  Coz that’s what I’m seeing.

    macmini@Fritz-Mac-mini ~ % nxserver –debug –enable all
    zsh: command not found: nxserver

    Perhaps I’m misunderstanding?

    #41666
    Britgirl
    Keymaster

    Hi Fritz, sorry I realised that in my reply the -- are not showing in the command.

    In any case, you need to use the full path to the nxserver e.g

    /etc/NX/nxserver/Applications/NoMachine.app/Contents/Frameworks/bin/nxserver --debug --enable all

    reproduce problem and then collect logs

    sudo /etc/NX/nxserver/Applications/NoMachine.app/Contents/Frameworks/bin/nxserver --debug --collect

    then disable

    sudo /etc/NX/nxserver/Applications/NoMachine.app/Contents/Frameworks/bin/nxserver --debug --disable all

    #41667
    Fritz
    Participant
    macmini@Fritz-Mac-mini ~ % sudo /etc/NX/nxserver --debug --enable all
    Password:
    NX> 900 Debug mode enabled for: server
    NX> 900 Debug mode enabled for: node
    NX> 900 Debug mode enabled for: agent
    macmini@Fritz-Mac-mini ~ % sudo /etc/NX/nxserver/Applications/NoMachine.app/Contents/Frameworks/bin/nxserver --debug --collect
    sudo: /etc/NX/nxserver/Applications/NoMachine.app/Contents/Frameworks/bin/nxserver: command not found
    macmini@Fritz-Mac-mini ~ %

    what am I doing wrong?

    #41673
    Fritz
    Participant

    here’s some more data.

    Again, mini is running Big Sur.  I have discovered that I cannot checkbox toggle:

    Allow guest desktop sharing ….. server.

    Make access available … login screen.

    Though that probably makes sense considering the other issues.

     

     

Viewing 15 posts - 1 through 15 (of 16 total)

You must be logged in to reply to this topic.