Can't connect to Mac

Forums / NoMachine for Mac / Can't connect to Mac

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #11184
    Avatarrahvee
    Participant

    I have a Mac running el capitan. I did some experimentation with nxclient, NoMachine Enterprise Client, and NoMachine. In the end, I decided I wanted just standard NoMachine (client & server) so I can remote control the Mac from another Windows pc on the same LAN. But I think during my experimentation, I must have messed something up, because no matter how I try to uninstall and reinstall, I can’t get the windows client to connect to the Mac server. The Mac has the !m icon in the status area, and Connections=on, and advertise this computer on the network. The Windows client automatically notices the Mac present on the network, but when the Windows client tries to connect to it, it just times out and says “did not respond.”

    I think this problem can probably be fixed by completely uninstalling any trace of any NoMachine product that was ever on the Mac, and then doing a fresh install of the standard NoMachine installation. What else can I do beside this?

    sudo rm -rf /usr/NX

    sudo rm -rf /Applications/NX*.app

    sudo rm -rf /Applications/nx*.app

    ps -ef | egrep -i ‘noma|nx’

    (kill all processes)

    #11196
    Avatarkroy
    Contributor

    Seems like a firewall issue. Try disabling it temporarily to check. If it helps, enable firewall again and add the following exceptions – nxd, nxserver.bin, nxclient.app.

    You can check if these services are with “Allowed” status in “System Preferences/Security & Privacy/Firewall/Firewall options”, if not – restart nxserver (in terminal use command sudo /etc/NX/nxserver --restart and click “Allow” in pop-ups with mentioned services.

    sudo rm -rf /Applications/NX*.app

    It’s not default NoMachine folder. It should be: sudo rm -rf /Applications/NoMachine.app. Moving NoMachine folder to trash via GUI should be sufficient to remove NoMachine from system. But if you try to do it from terminal – shutdown nxserver first (sudo /etc/NX/nxserver --shutdown) and check it all nx processes are closed like you did it earlier. After that you can remove folder safety.

    #11210
    Avatarrahvee
    Participant

    Thanks for the reply. Unfortunately, it sounds like you’re saying to do the stuff I already did (rm everything related to NoMachine or nx under /Applications, and kill any running processes) … and on Macs, the firewall is disabled by default. Mine is disabled.

    You also mentioned /etc/NX, but I observed, that directory gets created automatically when the service is running, and removed automatically when I kill the service.

    Aren’t there some config files in ~/Library, or /Library, or something else I can remove, to make it a more “clean” uninstall?

    #11211
    Avatarrahvee
    Participant

    Huh. Nevermind, I guess.

    I just tried it all again, with reboot, (exactly what I did before) and it’s working now. I have no idea why or what’s different.

    #11227
    AvatarBritgirl
    Keymaster

    Perhaps there were some processes left for whatever reason. If the issue comes back, let us know.

Viewing 5 posts - 1 through 5 (of 5 total)

This topic was marked as solved, you can't post.