Can’t connect to the NoMachine server after moving to a new server

Forums / NoMachine for Linux / Can’t connect to the NoMachine server after moving to a new server

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #42108

    Dear NoMachine team,

    I was successfully using headless-Ubuntu desktop from OS X with NoMachine. But after moving to a new IP address (because of mispayment some day for my cloud service) I can’t connect with password authentication to headless-Ubuntu via NoMachine anymore.

    My hell loop:

    First time NoMachine has several unsuccessful attempts to connect and eventually fails with the logs which is attached in file with name R-localhost-2009-6F16A8577822C9376F9F13DC2068B6D3 .

    All further attempts to connect finish with the message <No available desktops on this server> .

    Here is a list what I tried, but it didn’t help:

    1) sudo /etc/NX/nxserver –restart
    2) reinstallation of NoMachine on server side
    3) editing DefaultDesktopCommandefault at /usr/NX/etc/node.cfg into all possible options.

    NoMachine version: Version 8.2.3
    Ubuntu version: Ubuntu 20.04.5 LTS
    Ubuntu available desktops:
    $ grep ^Exec /usr/share/xsessions/*.desktop

    • /usr/share/xsessions/gnome.desktop:Exec=/usr/bin/gnome-session --session=gnome
    • /usr/share/xsessions/gnome-xorg.desktop:Exec=/usr/bin/gnome-session --session=gnome
    • /usr/share/xsessions/ubuntu.desktop:Exec=env GNOME_SHELL_SESSION_MODE=ubuntu /usr/bin/gnome-session --systemd --session=ubuntu



    Dear iv,

    In order to investigate, we need the logs from server side.

    More info on how to collect logs here in this article:

    Can you please send them by email to forum[at]nomachine[dot]com, making sure to reference the topic as the subject of the email?




    Dear katpan,

    I’ve sent logs to the email which you provided. But I’m not sure if it was delivered. Let me know if there are some problems.



    I confirm we received the logs, and we are investigating the issue.

    Thank you for your patience 🙂


    Hi iv,

    please try to run this command on the server machine and tell us if it reports any error:

    sudo /etc/NX/nxserver --eglcapture yes

    Then restart the display manager and the NoMachine server to make changes effective:

    sudo systemctl restart display-manager
    sudo /etc/NX/nxserver --restart

    Let us know if that solves the problem.


    Thank you!

    This solved my problem 🙂

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.