Can’t connect with a DDNS hostname

Forums / NoMachine for Windows / Can’t connect with a DDNS hostname

Tagged: 

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #41473
    YouDontKnowMu
    Participant

    Hi there,

    I just installed NoMachine 8.2.3 on my computer to access it from my Android mobile.

    Everything works flawlessly when i connect to the computer with NoMachine using the IP in NoMachine

    I use a DDNS (synology.me) on a regular basis since my IP changes everytime I reboot my modem.
    This DDNS pings with my public IP.
    Also I’m able to connect the computer in RDC using xx.xx.xx.xx:port

    But NoMachine doesn’t seem to work with the DDNS (even with another Windows client)

    Both
    PC to W10 using DDNS doesn’t work
    And
    Android to W10 PC using DDNS doesn’t work

    Both
    PC to W10 using IP works
    And
    Android to W10 PC using IP works

    Are you aware of an issue with DDNS ?

    I attached my settings, but everything should be OK (opened the ports, and this DDNS works with other services that I use)

    Thanks a lot for your answers ! =)

    Attachments:
    #41499
    Tom
    Participant

    Hi
    What router do you have?
    Can you connect to the computer via RDP using the name from the DDNS address?
    Are you setting up synology.me on your router?
    Connecting via NoMachine are you using the port generated by UPnP (141)?
    For testing, can you permanently forward port 4000 to the IP of the computer you are connecting to?

    Regards
    Tom

    #41503
    YouDontKnowMu
    Participant

    Hi,

    I have a FreeboxMini 4K as a router (it’s a French ISP).
    I can connect succesfully via RDP targeting my IP, or the DDNS address.
    I’m not setting up synology.me on the router, it’s the Synology NAS that register any new public IP that my modem/router gets to synology.me.
    I tested it, and everytime the IP changes, the DDNS is up to date in approx 20 secs, thus making pinging the DDNS giving me the proper public IP adress. (it changes approx once a month).
    I’m connecting with NoMachine using the port given in the connection string of the status screen (and yes, it’s opened correctly by UPNP, thus making the connection via IP successful, only the DDNS on does not work.)
    I tried stopping the UPNP port opening and opening it by myself, but it’s the same.

    I tried forwarding port 4000 to the IP of the computer, and it seems to be working, even if I set up the DDNS connection to aim port 24580 ? Implying any DDNS targeted NX connection aims port 4000 ?

    Is it a bug or anything ?

    Thanks

    #41537
    Tom
    Participant

    Hi,

    I have a FreeboxMini 4K as a router (it’s a French ISP).

    Unfortunately, I do not know this model and I do not know if it is possible to check in its logs why it does not work

    I tested it, and everytime the IP changes, the DDNS is up to date in approx 20 secs, thus making pinging the DDNS giving me the proper public IP adress. (it changes approx once a month).

    So we can assume that domain redirection from DDNS works fine.

    I tried forwarding port 4000 to the IP of the computer, and it seems to be working

    I don’t understand if the way without UPnP works or not? For simplicity, the incoming and outgoing ports should be the same. Incoming port 4000 on the router forwarded to port 4000 and the IP of the computer with NoMachine installed. Then when connecting from outside your local network you should enter in NoMachine Player the DDNS domain name and port 4000 to connect. Is this working?

    

even if I set up the DDNS connection to aim port 24580 ? Implying any DDNS targeted NX connection aims port 4000 ?

    Manually forwarded port is not needed to connect over the port shown by UPnP.

    Please take logs from NoMachine Client and Server and upload here or send direct to forum[at]nomachine[dot]com, instructions below on how to do this
    https://kb.nomachine.com/DT07S00243

    Regards
    Tom

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.