Can’t control mouse and keyboard (Windows server, multiple clients)

Forums / NoMachine for Windows / Can’t control mouse and keyboard (Windows server, multiple clients)

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #34870
    aaccioly
    Participant

    Hi, I have a Windows 10 box running the latest released version of NoMachine Server (7.6.2). It has a physical display attached to it.

    I access this box with both a Linux client (Ubuntu 20.04.2 / GNOME 3.36.8) and an Android client, both also running the latest version of NoMachine.
    Since a couple of weeks ago, while I can connect to the box, NoMachine is no longer sending keyboard and mouse events to it.
    The clock is updating fine, and if I move my mouse or open an application, I can see it happening through NoMachine, but if I try to click or type something using any of my clients it doesn’t work.

    You can find an image attached.

    Kind regards,

    #34912
    graywolf
    Moderator

    Hello.

    1. Has your Window 10 got any system update recently?

    2. Please use the Linux NoMachine client to connect to the Windows host and press/release all modifier keys (Alt, Shift, Ctrl) one by one. Are keyboard/mouse input still blocked after that?

    3. Run a command prompt on the Windows 10 host. Change dir to the installation path and run nxserver command to collect logs, i.e.:

    cd %ProgramFiles(x86)%\NoMachine\bin

    nxserver --debug --collect

    Send the log to forum (at) nomachine (dot) com

    4. Try to restart NoMachine service, and see if anything changed, i.e.:

    cd %ProgramFiles(x86)%\NoMachine\bin

    nxserver --restart

     

    #34944
    aaccioly
    Participant

    Hi graywolf,

    Thanks for getting back to me.

    1. Yes, regular Windows Updates. Currently running Windows 10 Pro 21H1 build 19043.1165

    2. Did that, unfortunately input still blocked.

    3. Done. Email title -> Logs requested – https……./topic/cant-control-mouse-and-keyboard-windows-server-multiple-clients

    4. Done, unfortunately no change.

    Thanks in advance for your help.

    #34989
    graywolf
    Moderator

    Please go to the server menu, Performance tab, and deselect “Use hardware encoder” and “Use acceleration for display processing”.

    In the client menu, deselect “Grab the keyboard input” and “Grab the mouse input”.

    Restart the server. Any changes?

    #35198
    aaccioly
    Participant

    Hi graywolf,

    Thanks for getting back to me again.
    Sorry for the long hiatus, I got busy with other stuff.

    Unfortunately disabling Hardware Encoder and GPU Acceleration didn’t make a difference other than the fact that just restarting the no machine server isn’t enough (it required me to physically restart the machine).

    Other than that, currently Moonlight is running fine (my current workaround to access the Desktop is Moonlight streaming mstsc.exe, although, for work purposes NoMachine works better for me), which leads me to think that GPU Encoding / Acceleration should be working fine (This machine has a somewhat dated GTX 1070 and it was working reliably with NoMachine for a while).

    Grab input options in the client were already deselected, but I tried to toggle both on and off just to be sure, no change.

    I also tried to uninstall the server with Geek Uninstaller and purge the client on my Linux box / install everything again. Unfortunately still no joy (I’ve made a backup of the old installation and restored it not to get in the way of the troubleshooting).

    I’ve sent you another batch of logs.

    Thanks again for your help and sorry for the hassle.

    Kind regards,

    #35325
    Carin
    Participant

    Hi aaccioly,

    Thank you for sending the new files. Unfortunately, it did not help to narrow down the problem.
    Would you be willing to install a debug package and collect some additional logs for us?

    #35333
    aaccioly
    Participant

    Hi Carin,

    Sure. Thanks for the helpful customer support. Just point me in the right direction and I’ll install it.

    Kind regards,

    #35364
    Carin
    Participant

    @aaccioly, You’re very welcome! Check your inbox 😉

    #35763
    aaccioly
    Participant

    Hi guys, just checking in to confirm if my logs were helpful at all.

    Kind regards,

    #35770
    Carin
    Participant

    Hi, aaccioly,

    Sorry for the delay.
    We received your logs. However, we could not see the debug messages in the logs.
    Could you please try again, this time completely removing the existing installation prior to installing the debug package? Thank you!

    #35791
    aaccioly
    Participant

    Hi Carin, how are you?
    Before running the custom server I had already fully removed the previous version.
    Maybe I did something wrong during the collection, can you verify what I did bellow?

     

    1. Uninstalled the previous version
    2. Installed the package on the server (do I also need to install it on the client?)
    3. Run nxserver –debug –enable all
    4. Reproduced the problem
    5. Created the archive with: nxserver –debug –collect

    Is the order correct?

    Kind regards,

    #36105
    Carin
    Participant

    Hi aaccioly,

    We have sent you a new debug package with further messages enabled. Please check your inbox. 😉

    In addition, you may check the view-only mode status configuration as suggested in the articles below:
    https://knowledgebase.nomachine.com/DT10R00171#12.2
    https://knowledgebase.nomachine.com/DT10O00155#2.2

    #36494
    aaccioly
    Participant

    Hello Carin,

    How are you?
    It appears that version 7.7.4 has fixed the issue for me. I can now control my Windows Machine fine. I’ve sent some logs to the forum’s email address just in case you can spot the difference.

    Thanks for all of your help!
    Kind regards,

Viewing 13 posts - 1 through 13 (of 13 total)

This topic was marked as solved, you can't post.