Can't create new virtual desktops

Forums / NoMachine Cloud Server Products / Can't create new virtual desktops

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #396
    Avatarigor
    Participant

    Hi,

    I’m testing Enterprise Server + Node, v 4.0.360-3.x86_64 on RHEL 6.3 (Server,Node) and RHEL 5.8 (Node) and I’m having problems starting a session with virtual desktop. I can see the nodes added to the server fine, virtual desktop is enabled (it is by default anyway) and I can connect to the server (NX, 4000), connection to physical desktop works fine. However, when I try to create a virtual desktop (which is what I really want as thinking of migrating from NX Enterprise Server 3.5) a new desktop never gets created, client just show spinning circle.

    I enabled debug on the nodes and I get this when creating virtual desktop:
    16:47:55:430.937 NXNODE-4.0.360[38228] DEBUG: NXPL::NXTryBind start.
    16:47:55:430.980 NXNODE-4.0.360[38228] DEBUG: NXPL::NXTryBind stop.
    16:47:55:431.014 NXNODE-4.0.360[38228] DEBUG: tcp port ‘12001’ is free
    16:47:55:431.068 NXNODE-4.0.360[38228] DEBUG: check display resources passed for display ‘1001’
    16:47:55:431.131 NXNODE-4.0.360[38228] DEBUG: Sent response message: 1025, with parameters: ”
    16:47:55:441.493 NXNODE-4.0.360[38228] DEBUG: Service is [closeConnection], parameters is []
    16:47:55:441.541 NXNODE-4.0.360[38228] DEBUG: Left in buffer is:
    16:47:55:441.624 NXNODE-4.0.360[38228] DEBUG: Message BYE sent to server
    16:47:55:441.667 NXNODE-4.0.360[38228] DEBUG: Finalize process.

    Could you please help as I’m trying to evaluate the new version.

    Thanks!

    Igor

    #437
    Avatarigor
    Participant

    Installed latest release of enterprise-server-362_2 and terminal-node-362_1 (enterprise-node not available for download anymore?) and it works now. However, I noticed it is sensitive on the way a node has been added on the machine running the nx server – needs to go as localhost, not as hostname.

    Also: available desktops still show physical desktops although they’re removed and EnableVirtualGL doesn’t work (there’s VirtualGL install and configured and manually with vglrun applications run fine).

    #440
    Avatarsil04
    Keymaster

    Hi igor,

    enterprise-node not available for download anymore?

    The enterprise-node package was renamed terminal-server-node to make more clear that such package works as an additional Linux Terminal Server node of an Enterprise Server whose nodes can be also a Windows or Mac hosts.

    The enterprise-node package was renamed terminal-server-node to make more clear
    that such package works as an additional Linux Terminal Server node of an Enterprise Server whose nodes can be also a Windows or Mac hosts.

    Can you please provide the commands you gave on the server to add the node and the corresponding output? More than being sensitive to the hostname given, can be that the node was not added due to some other reasons.

    available desktops still show physical desktops

    This is a bug. If the PhysicalDesktopSharing key is disabled is the server configuration, users must not see the physical desktop listed among the available sessions.

    EnableVirtualGL doesn’t work

    NoMachine 4.0.362 is not able yet to provide hardware support for OpenGL in an automatic way, so it’s not enough to enable it in the EnableVirtualGL key. It’s necessary to execute some manual operations:

    – Run the following script

    /usr/NX/scripts/vgl/vglserver_config -config

    – Reboot the machine.

    – Then launch the OpenGL application by running inside the NoMachine session:

    /usr/NX/scripts/vgl/vglrun <opengl app>

    #591
    Avatarigor
    Participant

    Hi,

    No issues with the node packages – just observation, I assumed they’re the same. I suppose depending on the license it will behave differently.

    Can you please provide the commands you gave on the server to add the node and the corresponding output? More than being sensitive to the hostname given, can be that the node was not added due to some other reasons.

    Nodes were added fine but I found their performance degraded if any changes were made on the node which lives on the same machine where also NX server lives.

    I was changing some logging options (destination and log level) on the nodes and found that nodes would randomly start to run extremely slowly even when I’d revert changes. I still didn’t figure out which change would cause this. Restarting of NXServer daemon would fix it but is not the nicest way to solve this. I will test a bit more and come back about it.

    available desktops still show physical desktops
    This is a bug. If the PhysicalDesktopSharing key is disabled is the server configuration, users must not see the physical desktop listed among the available sessions.

    I disabled PhyscialDesktopSharing in server.cfg, restarted nxserver but I still get physical desktops offered in session list.

    I’m already using VirtualGL with version 3.5 without problems and was hoping there’s an automatic way now to provide 3D acceleration in version 4. Is there any time frame when it would be available? Thanks for help!

    Igor

    #594
    Avatarsil04
    Keymaster

    Hi igor,

    I’m already using VirtualGL with version 3.5 without problems and was hoping there’s an automatic way now to provide 3D acceleration in version 4. Is there any time frame when it would be available?

    In the 4.1 we run here, VirtualGL is now the default. Unfortunately I cannot give any release date yet.

    #595
    Avatarsil04
    Keymaster

    Nodes were added fine but I found their performance degraded if any changes were made on the node which lives on the same machine where also NX server lives.

    I was changing some logging options (destination and log level) on the nodes and found that nodes would randomly start to run extremely slowly even when I’d revert changes. I still didn’t figure out which change would cause this. Restarting of NXServer daemon would fix it but is not the nicest way to solve this. I will test a bit more and come back about it.

    I suspect this can be due to some process becoming confused and entering an infinite loop.

    Please run top when this happens and see if there is any process showing at 100%.

    If you can, also attach with gdb and see if you can take a backtrace.

    Otherwise get in contact with our support so they can provide instructions on how to do that.

    • This reply was modified 7 years, 5 months ago by Avatarsil04.
    #644
    Avatarigor
    Participant

    Thanks for your replies. At the moment it’s working OK, I’m testing it with few user so will not be changing much until I pass this instance of testing.

    Just one questions on access to physical desktops. I have disabled access to physical desktops in both server.cfg and node.cfg but they still show in the menu. I set virtual desktop to be automatically created but with no effect – the client still shows all options. Checking use as default when selecting virtual desktop does work though.

    I will come back with debug regarding the slow down but I think I saw nxnode processes (more than one) running at 100% when this occurred. It’s working stable now, no issues at the moment.

    Regards,

    Igor

    #648
    AvatarBritgirl
    Keymaster

    Igor, I have opened a new topic for your question about disabling physical desktops.

    https://www.nomachine.com/forums/forums/topic/access-to-physical-desktop-on-terminal-server

    • This reply was modified 7 years, 5 months ago by AvatarBritgirl.
Viewing 8 posts - 1 through 8 (of 8 total)

This topic was marked as solved, you can't post.