Cant figure out how to connect

Forums / NoMachine for Windows / Cant figure out how to connect

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #1961
    Avatarpcfixme
    Participant

    I have 3 computers, 1 at the office and 2 on the home network.  I am able to connect the 2 at the home network to each other and remote in, but I cant for the life of me figure out how to connect my home to my office pc or vice versa.  I get Error 138 connection timed out.

    At the home network it is a ATT uverse 2 wire gateway that doesnt allow upnp, so I tried to add tdcp 4000 -4000 port and udcp 4347?

    If someone could please give me a thorough step by step for windows 7 based machines I would greatly appreciate it.

    at the office it is a netgear router and allows for upnp .   Im sure it is something to do with the firewall.

    At the home network i connect using nx://192.168.x.x but to connect to the office pc i need to type nx://108.xxx.xxx.xxx?

     

    Please help!  thank you!

    #2002
    AvatarBritgirl
    Keymaster

    If you connect from a PC on the same network, you have to use the internal IP which you have done correctly. When you connect from a PC on an external network, you need to use the Gateway IP instead. Your office’s external IP address should be shown in the Gateway IP field (in your case 108.xxx.xxx.xx)  which you obtain by opening the GUI from the menu and clicking on the penultimate icon on the right (Server settings). It takes you to the Forwarded ports panel by default. Write down this IP address along with the port number shown next to NX:….  This information is what you need to use in the connection GUI when connecting from home. Make sure that the checkbox for NX is ticked.

    If you did this, and you are still getting the connection error, then it’s either a firewall issue or a router issue. In that case you will need to configure your office router to forward a suitable port to your local IP port 4000 (NoMachine uses 4000 by default).

    To connect from home, you then use your office’s external IP address and the port that you either obtained from the Forwarded ports panel or which you configured manually on the router.

Viewing 2 posts - 1 through 2 (of 2 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.