Can’t find remote drive

Forums / NoMachine for Windows / Can’t find remote drive

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #42151
    _Frog_
    Participant

    Hi,

    I update “recently” the free NoMachine client (W10 – NX 8.2.3) and the free NoMachine server (Debian/Sid – NX 8.2.3). When I go to share drive, I can see the Windows drive c:\ as local drive, but I have nothing under remote drive.

    I try to find an answer in configuration file (and forum), but find nothing about it. At least, I would like to have /home/user/ and I would mount everything inside it.

    Any idea ? I’m using SCP which is less user – friendly than a real mount.

    Thx in advance,

    #42448
    Britgirl
    Participant

    Hi, we are not aware of issues with sharing remote drives from Debian to Windows.

    You say you updated. Was disk sharing working for you in the earlier version?

    Logs from the server side would be useful. Enable debug on the Debian machine, reproduce the problem and then gather up the logs. You can send them to forum[at]nomachine[dot]com making sure to use the title of the topic as the subject of your email.

    $ sudo /etc/NX/nxserver –debug –enable all
    $ sudo /etc/NX/nxserver –debug –collect

    (from the following guide https://kb.nomachine.com/DT07S00243, Collect server side logs automatically)

    #42460
    Majkl
    Participant

    What previous version was the upgrade from?

    We have about 30 users. Most users had a problem with disk mapping after upgrading the client from NXv6/7 to NXv8 (32-bit), uninstalling NMv8 32-bit and installing NMv8 64-bit, but the disk was still not mapped. We are using NoMachine Enterprise Client on Windows 10.

    For all of them, the problem was solved by uninstalling the client, rebooting, finding all occurrences of NX files (especially .nx directories in the profile or parts of the old installation that might have been under the user’s profile) and manually deleting them, rebooting, a new installation of NX client 8.2.3 – and the drives started connecting again.

    The problem on the client side, the server side could be different (and in the debug log of the server it appeared that the disk for sharing was offered to the client, but it did not appear in the menu in the client). But it could be that we normally manage the install/uninstall/upgrade centrally with ZenWorks and it appeared that there was a remnant of the previous version somewhere that caused the conflict.

    We still have some disk issue on the client side, but that probably only applies to the published application mode (Terminal server edition) and not the whole desktop sharing.

    (Britgil: Please, did you get the debug log emailed about the falling ED?)

    #42471
    Britgirl
    Participant

    Thanks for the additional information.

    And we got the logs for https://forums.nomachine.com/topic/user-unable-to-connect-to-nomachine-after-reboot as well 🙂

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.