Can’t get sound working on Mac

Forums / NoMachine for Mac / Can’t get sound working on Mac

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #30677
    Avatarjortay
    Participant

    Hi,

    I’m on a iMac running High Sierra (10.13.5), and I can connect to this computer remotely using NoMachine (6.13.2 on both machines), but can’t get the audio working.  “NoMachine Audio Adapter” is not showing up in my sound output prefs, which I believe is a problem.  Any advice on how to fix?

    Thanks!

    #30680
    Avatartsotne
    Participant

    Hello,
    firstly, please check if you did approve kernel extensions (see article about it)

    if yes,
    1. let’s load nxaudio kext manually:

    sudo kextutil -vvv /System/Library/Extensions/nxaudio.kext/

    2. if you already approved, skip this step:
    Access System Preferences -> Security&Privacy -> General panel. Click on the “Allow” button

    3. if it finished without any error, check if it’s loaded properly:
    kextstat | grep nxau

    you should get similar output:
    180    0 0xffffff7f83d9c000 0x5000     0x5000     com.nomachine.driver.nxau (4.1.b2) 78172556-B6A4-3112-BA41-E79D18108476 <93 6 5 3 1>

    4. restart NoMachine server:
    sudo /etc/NX/nxserver --restart

    If audio still does not work, please send us the output of kextutil command (point 1) in your reply.

    #30745
    Avatarroystech
    Participant

    I have the same issue, only with Big Sur (yes, the Intel version). Doesn’t look like the kext is being installed all, and the installation was successful.

    #30748
    Avatartsotne
    Participant

    Hello, for newer versions of Mac OS, nxaudio kext is located in different place.

    please, try:

    1. let’s load nxaudio kext manually:

    sudo kextutil -vvv /Library/Extensions/nxaudio.kext/

    2. if you did not approve it, do:
    Access System Preferences -> Security&Privacy -> General panel. Click on the “Allow” button

    3. if it finished without any error, check if it’s loaded properly:
    kextstat | grep nxau

    you should get similar output:
    180    0 0xffffff7f83d9c000 0x5000     0x5000
    com.nomachine.driver.nxau (4.1.b2) 78172556-B6A4-3112-BA41-E79D18108476
    <93 6 5 3 1>

    4. restart NoMachine server:
    sudo /etc/NX/nxserver --restart

    If audio still does not work, please send us the output of kextutil command (point 1) in your reply.

    #30754
    Avatarroystech
    Participant
    user@users-iMac-Pro ~ % sudo kextutil -vvv /Library/Extensions/nxaudio.kext/
    Password:
    Defaulting to kernel file '/System/Library/Kernels/kernel'
    Executing: /usr/bin/kmutil load --bundle-path /Library/Extensions/nxaudio.kext
    user@users-iMac-Pro ~ % kextstat | grep nxau
    Executing: /usr/bin/kmutil showloaded
    No variant specified, falling back to release
    125 0 0xffffff7fa164a000 0x3000 0x3000 com.nomachine.driver.nxau (4.1.b2) 78172556-B6A4-3112-BA41-E79D18108476 <70 6 5 3 1>
    user@users-iMac-Pro ~ % sudo /etc/NX/nxserver --restart
    NX> 162 Disabled service: nxserver.
    NX> 162 Disabled service: nxnode.
    NX> 162 Disabled service: nxd.
    NX> 111 New connections to NoMachine server are enabled.
    NX> 161 Enabled service: nxserver.
    NX> 161 Enabled service: nxnode.
    NX> 161 Enabled service: nxd.
    user@users-iMac-Pro ~ %

    Nope. Uninstalled and reinstalled with same results.

    #30759
    Avatartsotne
    Participant

    It seems nxaudio loaded.

    So tell us whether:
    1.  you see NM Audio Adapter in Audio MIDI Setup? if yes, is it set as default?

    and check
    2. you have specific user microphone permission in System Preferences –> Security&Privacy?

    Please, attach screenshots of that settings.

    #31327
    AvatarBritgirl
    Keymaster

    Please update to the latest version of NoMachine and if you still have issues, please open a new topic and attach the screenshot of the permissions in Security/Privacy. Thanks!

Viewing 7 posts - 1 through 7 (of 7 total)

This topic was marked as closed, you can't post.