Can’t get the system menu item to show up

Forums / NoMachine for Linux / Can’t get the system menu item to show up

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #31401
    Avatarsenigami
    Participant

    I initially downloaded ‘nomachine_7.0.211_4_i386.deb’ to install on my Linux Mint, (thinking I had done a 32 bit installation on this particular machine)  Everything installed fine and I tried opening the app with the system menu (it was showing up at this point) nothing would open.  I tried the service, still nothing.  I realized that I should have installed the 64 bit version.  I didn’t know how to uninstall it but found instructions on https://www.nomachine.com/AR01L00775 .

    Unfortunately I ran the deb uninstall script “sudo dpkg -r nomachine” instead of the tar instructions “sudo /usr/NX/scripts/setup/nxserver –uninstall”  I noticed I was getting errors and then canceled the uninstall and tried the proper uninstall.  I got errors of not being able to stop the NX service.  I figured it was best to reinstall the i386 version to put everything back and then to do a proper uninstall.

    After uninstalling the i386 version, (still with nx service errors) I then launched ‘nomachine_7.0.211_4_amd64.deb’ and proceeded to install only my Linux Mint 19.1 system.  I cannot get the menu items to show up.  I’ve tried uninstalling, reinstalling and nothing I do will get the menu items to restore.  I have no idea how to launch this interface.

    #31464
    Avatarsenigami
    Participant

    I upgraded my system to mint 20.1 hoping that would fix the problem.  Still cannot get this to show up in the menu.  Very frustrating.  I know I’m not an expert with Linux but I would imagine that if I knew what the command line was to start the app I could create my own start icon and manually link it.

    #31477
    Avatarkroy
    Contributor

    Hi.

    Please uninstall NoMachine with following command:

    sudo dpkg --purge nomachine && sudo rm -rf /usr/NX /etc/NX /var/NX .nx

    It will remove program and all its configurations from the system. Then you will be able to install NoMachine properly.

    #31501
    Avatarsenigami
    Participant

    Thank you!  You are a genius! This is exactly what I needed.  I’m actually typing this on a remote machine using NoMachine right now.  So cool!

Viewing 4 posts - 1 through 4 (of 4 total)

This topic was marked as solved, you can't post.