Can’t get USB sharing working

Forums / NoMachine for Linux / Can’t get USB sharing working

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #34233
    Avatarkdv666
    Participant

    Hello.  I was determined to get this solved myself, and I have spent a lot of time going through the docs and forums.  But I’m stumped.  I’m sure it’s been solved before, and even a pointer to the solution would be great!

    My situation:

    Server: Ubuntu Mate 20.04, Nomachine 7.6.2 linux

    Client: Ubuntu Mate 20.04 Nomachine 7.6.2 linux

    I can open the client session with no problems.  But when I go to the menu and tell it I want to import a USB device, the Local section is empty.  I should add that I have plugged the device ( A Logitech Remote Controller ) in to the client, and it is listed in the “lsusb” output.

    But on the server side … nothing!

    I’ve done a few checks after reading previous posts.  /usr/NX/bin/drivers/nxusb.ko does exist on both machines.  lsmod does not show the module in use when the nx software is running.  I can’t see any clues in any of the logs … I do a “grep -i nxusb *.log”, and I get a couple of errors from nxerror.log ( Unknown option: usbport ), and some normal looking commands from nxupdate.log and nxinstall.log.

    I’d really like to know what I’m missing here.  I’m happy to do the work, but I don’t know what work I should be doing!

    TIA

     

    #34245
    Avatarfisherman
    Moderator

    Please check following article for compiling drivers: What to do if USB support is disabled on Linux with NoMachine 6 or later installed

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.