Can’t login “Authentication failed, please try again.”

Forums / NoMachine for Linux / Can’t login “Authentication failed, please try again.”

Viewing 15 posts - 16 through 30 (of 60 total)
  • Author
    Posts
  • #25833
    AvatarBritgirl
    Keymaster

    Yes, hit reply to the last received email you got from us and attach them to that. We haven’t received any email with attachments from you other than those from a couple of weeks ago.

     

    #25942
    AvatarZenith
    Participant

    Can you please let me know if you got/found the e-mail and if I should send it again?

    Thanks in advance!

    #25945
    AvatarBritgirl
    Keymaster

    We haven’t receive anything. It is possible for you to share them via Google drive or similar? We can download from that.

    #25956
    AvatarZenith
    Participant

    Yes sorry, I didn’t see your first reply on the second page here before sending that. In the meanwhile I replied to your last email, it was send on March the 13th at 17:08 (5:08 PM I believe). Please let me know if you have received it!

    Thanks in advance

    #25978
    AvatarBritgirl
    Keymaster

    Zenith, your email provider has been blocked for spamming. This is why we are not receiving the latest emails from you. Please send them from an alternative email address. Thanks!

    #25979
    AvatarZenith
    Participant

    Done! 🙂

    #26046
    AvatarMth
    Contributor

    Hello

    It is still not clear why the authorization is failing.
    We have:

    ERROR!Authentication failed with error 7.

    Which does not help as it is generic, authentication failed error.

    To get the proper information, you need to check the system logs to see what happens during the authentication. Most common place to look
    would be /var/log/auth.log file.

    Entries to look for would include

    pam_unix(nx:auth)

    If  you are sure the other system authentication methods work, you can try using the ssh protocol to connect to the server.

    From the player application you right click the connection, chose the “Edit” option and then change protocol to SSH. This will use the SSH authentication, so
    the nx pam.d configuration will be ignored.

    /Mth

    #26113
    AvatarZenith
    Participant

    In the player in Windows I can’t choose anything else then NX, there are no other options. In the server on Linux I can’t find an option to change the protocol either. Although I’m quite sure there have been more options available in the past, showing on the ‘Server status’ tab. In the box under ‘Use an IP from the list to connect to this desktop’.

    Now I also can’t even reach the login part in the player anymore:

    The connection to the server was lost.

    Error: Server is stopped

    While the server is clearly running. I restarted the server a few times to see if that fixed it, but it didn’t. I also restarted the player a few, but that didn’t fix anything either.

     

    In the auth.log file I see pam_unix entries, but nothing about ‘nx’ or pam_unix(nx:auth). The log mentions authentication failures and even ‘3 incorrect password attempts’, while like I said I couldn’t even reach the login part in the player this time…

    So I will e-mail those auth.log files (there’s also a auth.log.1), the last one contains some errors about port 22 (SSH). This is because I tried to change the port manually, since I couldn’t change the protocol.

    I also ran this command again: sudo /etc/NX/nxserver --debug --collect

    And I will add this zipped package to the e-mail as well.

    If this result in a solution, is there any change I could get some remote support? Because this is going on for more then over two months now.

    Thanks in advance

     

    #26123
    AvatarBritgirl
    Keymaster

    If this result in a solution, is there any change I could get some remote support? Because this is going on for more then over two months now.

    We can’t provide remote support directly on your host. This is a service we offer to customers with subscriptions (they have a customer area where they submit support enquiries) The forums is a free service we offer. We can’t guarantee that all problems reported to us on the forums can be resolved timely, although I can assure you that we do our best. If you submit the information we have requested as quickly as possible, it would naturally make the whole process go more quickly. Please submit the debug logs as Mth requested making sure you use the last email adopted to avoid our spam filter blocking your emails.

    The alternative is to completely uninstall everything, remove all traces and reinstall from scratch. NoMachine works out of the box in the majority of scenarios and on hundreds of Linux distributions and shouldn’t need advanced editing of any cfg files. Editing these from the start can mess with the correct functioning of the software. So IMHO the safest and quicker option is to start again.

    #26160
    AvatarZenith
    Participant

    I understand you can’t provide remote support for non paying users, but I thought I’d ask. You never know 🙂
    If I would purchase the ‘NoMachine Enterprise Desktop Subscription for Linux’ for $44.50, would that entitle me to remote support?

    For now I’ll first try to re-install and see if that fixes anything. Should I install the ‘NoMachine Enterprise Client or the Terminal Server Node package’ as well? Because I think I did do that last time.

    #26166
    AvatarZenith
    Participant

    NoMachine works out of the box in the majority of scenarios

    I would agree, the installation process and the software seems really straight forward. And only when I try to login on my Windows machine I have a problem. I feel it must be such an easy solution, because it can’t be (this) hard… I still think it’s a wrong username or password.

    I re-installed NoMachine and everything went fine, up to the point of trying to log in on the Windows player. Again I get the error: “Authentication failed, please try again.”

     

    #26174
    AvatarBritgirl
    Keymaster

    Should I install the ‘NoMachine Enterprise Client or the Terminal Server Node package’ as well? Because I think I did do that last time.

    You seem to be referring to our legacy version where users had to install 3 separate packages. This is no longer necessary with the latest version, well, since version 4 to be honest. It’s been one simple package for users to install since 2013. Additionally, you can’t install multiple packages on the same host, the installation will block. If you’ve had old NX products running on the same host where you’ve installed NoMachine, and here I am referring to NX-derivatives in particular, this could be what is causing all the problems. You should remove all of these if they are present.

    For more information about our support services associated with Enterprise Desktop, please check the appropriate web page. Remote access is only offered in specific circumstances: https://www.nomachine.com/support-services

    Regarding the original issue in question, now that you have done a complete removal and reinstall on the Linux server and have left it in it’s default factory configuration, I suggest you connect to reproduce the authentication problem, and gather the logs from both the Windows client (with the latest NM 6.9.2 package as well) and the Linux host, and you submit them as you did before. Please submit them as two attachments, one complete set for the connecting client, one for the server.

    #26278
    AvatarZenith
    Participant

    Do I also have to carry out these steps?:

    Step 1 – Set debug level in server.cfg
    Edit /usr/NX/etc/server.cfg, uncomment and set the following:
    SessionLogLevel 7

    If the problem affects web sessions, set also:
    WebSessionLogLevel 7

    Step 2 – Set debug level in node.cfg
    Edit /usr/NX/etc/node.cfg, uncomment and set the following:
    SessionLogLevel 7
    and:
    SessionLogClean 0

    Btw, when reinstalling NoMachine server on my Linux machine I didn’t install additional (separate) packages. I also had a ‘great’ idea last week. I borrowed my parents laptop, which is pretty new and they hardly use it. I just installed a few programs on it for them. So it’s a pretty uncompromised laptop if you understand what I mean. I installed the player on that and yet again got the same ‘Authentication’ error. So it’s not my Windows machine it seems.

    I will gather the logs on both machines like you said. The clean install of NoMachine on the Linux machine is left in it’s default configuration this time. I only have to know if I have to change the debug levels in the config file like the instructions mention on this page:

    https://www.nomachine.com/DT10O00163#1.1

    #26280
    AvatarZenith
    Participant

    One small addition to my last post, what do you mean with: “with the latest NM 6.9.2 package as well” ? Just the latest version of the player? And if so, how can I check the version on the player?

    #26308
    AvatarBritgirl
    Keymaster

    Submit the logs as requested including the steps (given you are using the free version which doesn’t support web sessions, there is no need to set the debug level for web sessions).

    If you have Enterprise Client installed, open the GUI, click on Settings -> Preferences -> Updates. If you have the free NoMachine (server/player combined package) on your Windows host, see:

    https://www.nomachine.com/DT11M00106#3.6.

Viewing 15 posts - 16 through 30 (of 60 total)

This topic was marked as solved, you can't post.