Can’t login “Authentication failed, please try again.”

Forums / NoMachine for Linux / Can’t login “Authentication failed, please try again.”

Viewing 15 posts - 46 through 60 (of 60 total)
  • Author
    Posts
  • #27121
    AvatarZenith
    Participant

    Hey brotech,

    I collected all the files you requested and e-mailed them. I wasn’t able to copy nxserver.log at first, so I ran this command to get that file:

    sudo /etc/NX/nxserver –debug –collect

    After that I tried again and then I could copy the nxserver.log file. but just in case I also added the zipped debug log file.

    If you need any more information, please let me know!

    #27146
    Avatarbrotech
    Participant

    Hello Zenith,

    logs which you sent don’t have enabled debug for NXServer. And so I cannot help you.

    Please to run this command on the server host:

    sudo /etc/NX/nxserver --debug --enable server

    You should see ouput as:

    NX> 900 Debug mode enabled for: server
    

    What does nxserver report to you when you run that command?

    #27152
    AvatarZenith
    Participant

    I get:

    NX> 500 ERROR: Cannot enable debug mode for: server.
    NX> 500 ERROR: Key SessionLogLevel does not exist in /usr/NX/etc/server.cfg.

    How can I fix that or what should I do next?

    #27166
    AvatarGega
    Participant

    Hello Zenith,

    It looks like server.cfg file contains Windows line endings. This might be inserted by the text editor you have used to modify server.cfg.

    Nxserver isn’t able to parse server.cfg in correct manner. To fix this you should run:

    dos2unix /usr/NX/etc/server.cfg

    dos2unix /usr/NX/etc/node.cfg

    You will have to install dos2unix, if it’s not available out of the box.

    After that run:

    /etc/NX/nxserver --restart

    And if problem still persists, than run:

    /etc/NX/nxserver --debug enable server

    Reproduce problem, collect logs and send it to us. Also please use another text editor for modifying server.cfg node.cfg, to avoid similar problems in the future.

    #27184
    AvatarZenith
    Participant

    Ok, I followed all the steps and e-mailed the results.

    #27208
    AvatarGega
    Participant

    It looks like you’re using NX password database and we see “wrong password or login” error which wasn’t enough for us to understand without the debug (we are going to improve this :-))

    2020-05-05 21:29:20 227.284 31346 NXSERVER ERROR! Authentication with ‘NX-password’ from host ‘192.168.1.15’ failed. Error is ‘Wrong password or login’.

    From server.cfg:

    #

    # Enable or disable NX password DB:

    #

    # 1: Enabled. Use NX password DB to authenticate users.

    #

    # 0: Disabled. Use SSHD + PAM authentication.

    #

    # System administrators can enable a restricted set of users to con-

    # nect to NX Server by setting EnableUserDB to 1 and adding

    # those users to the DB. If user is enabled to connect, his/her pass-

    # word will be verified against the current PAM settings by the SSHD

    # daemon.

    #

    # If both ‘EnableUserDB’ and ‘EnablePasswordDB’ are set to 0, any

    # user being authenticated by SSHD account will be enabled to connect

    # to the system.

    # EnablePasswordDB 0

    If you want to use system authentication, than remove ‘#’ from that last line, it should say:

    EnablePasswordDB 0

    If it’s intended, than you should set password for that user using:

    nxserver --passwd <user>

    #27215
    AvatarZenith
    Participant

    It works now!!! Omg.

    I have to do a clean install now on my Windows machine, if I install NoMachine and it works again I will report back here! 🙂

    #27216
    AvatarZenith
    Participant

    How can I make it fullscreen btw? When I click fullscreen now, I still get like a 15″ screen on my 27″ monitor on my Windows PC.

    #27218
    AvatarZenith
    Participant

    It worked, now I just wanted to try it again and I get this error:

    “The session negotiation failed”.

    What’s that all about?

    #27233
    AvatarGega
    Participant

    Please take a look at this article and see if it helps: https://www.nomachine.com/AR08N00898

    If not, then we will require new set of logs to continue investigation.

     

    About full screen, you could try enabling “Resize remote screen” and “Fullscreen” from settings>Display.

    #27356
    AvatarZenith
    Participant

    I got it working (again), for some reason ‘accepting connection(s)’ was disabled on the Linux machine. I didn’t to this myself as far as I know, so no clue why this happened.

    I still don’t have full screen though, despite manually entering the resolution. But currently the Linux machine is connected to a 640×480 (back up) monitor, so that could be the issue. I’ll test tomorrow without a monitor connected to the Linux machine.

    #27379
    AvatarZenith
    Participant

    It’s ‘full screen’ now, but it’s in a low resolution (Fit to screen). The display settings mention ‘1024 x 768, codec H.264’ in the left bottom while there is no monitor connected to the Linux machine. All the options are unchecked, except ‘Use custom resolution upon connecting’, but that doesn’t seem to do anything. I have a 2560 x 1440 monitor and I would like the Linux machine to be in the same resolution, is that possible?

    It’s also extremely slow/laggy to the point it’s basically unusable. Can I fine tune the network and/or fps settings to make it go smoother then this? I often use [removed] to help people remotely and even that is way faster then this. And that’s over the internet… So I feel it should be possible to run NoMachine with the NX protocol over LAN way faster.

    Thanks in advance

    #27383
    AvatarBritgirl
    Keymaster

    Zenith, just to confirm because this topic is quite long (in theory it would be wiser to open a new topic about performance), you are connecting from Windows to Linux, aren’t you? In any case, regardless of the OS you are connecting, when connecting to the physical desktop, the supported resolutions are those of the remote graphics card as listed in the System settings on the server. I.e., the session resolution on the client cannot be higher than the maximum resolution supported by the remote graphics card which in your case is on the Linux host you are connecting to.

    More information is here:
    Resize and scaling options for NoMachine client version 4 or later
    https://www.nomachine.com/AR02M00835

    About performance. You can check a few things.

    1) Check CPU usage, on the client but more importantly on the server

    2) What changes when you move the Quality slider during the session?

    3) Try switching off the X-server, that way NoMachine will activate its own. This article explains how to do that. https://www.nomachine.com/AR03P00973. If you read there, also look at points 3 and 4).

    Can you also look in the session in the C-*/session logs to see what is written there with regards to H.264?

    If you get:

    Info: Using H.264 software encoder.

    the encoding is done by the CPU, otherwise you’ll get “hardware encoder” if it is done by the GPU.

    #27449
    AvatarZenith
    Participant

    Hey Brit,

    You’re probably right. Although it seems already to be fixed. It’s pretty weird, with no monitor connected to the Linux machine I get those performance issues. But as soon as I connect my TV (even on standby), the problems are over and I get full screen in 1080p and a smooth experience.

    Is there a logic to that? That NoMachine has a problem with headless machines? Also if I add a GPU to my system instead of using an onboard (i)GPU, would the GPU still do the work without a monitor or TV connected? Or the TV on standby? Or is that the X-server thing you’re talking about?

    Also, as a conclusion I would like to know what I did wrong in the end. Was at simple as this?:

    If you want to use system authentication, than remove ‘#’ from that last line, it should say:

    EnablePasswordDB 0

     

    #27603
    AvatarBritgirl
    Keymaster

    Installing NX and logging in with system credentials works out of the box. Changing the cfg files original settings should be done provided you understand what you are changing and why.

    In its default installation EnablePasswordDB in the server.cfg is set to ‘0’ which means we do not use our password db, but use the system authentication method.

    You edited the server.cfg using Windows tools, and in doing so (for which we have opened the following feature request by the way https://www.nomachine.com/FR05R03981) nxserver lost its ability to read the server.cfg properly and so NX password db became enabled and you user could no longer login using system credentials.

    Something good came out of it. We discovered that Windows editors misbehave when editing unix files, so we will improve the software to make sure this doesn’t happen 🙂

    Is there a logic to that? That NoMachine has a problem with headless machines? Also if I add a GPU to my system instead of using an onboard (i)GPU, would the GPU still do the work without a monitor or TV connected? Or the TV on standby? Or is that the X-server thing you’re talking about?

    No, NoMachine doesn’t have a a problem with headless machines. The logic is rather simple: if there is no monitor attached, the GPU can’t function. It’s not NoMachine that isn’t working. You can consider purchasing a dummy dongle. This will make your system think there is a monitor attached and the GPU will function correctly. Then NoMachine will use HW encoding. Search these forums for the word “dummy dongle” and you will see other users who did the same.

Viewing 15 posts - 46 through 60 (of 60 total)

You must be logged in to reply to this topic.