Can’t login to NoMachine using an AD user account (Ubuntu Cloud Server)

Forums / NoMachine for Linux / Can’t login to NoMachine using an AD user account (Ubuntu Cloud Server)

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #28539
    Avatartom5
    Participant

    Hello,

    When initially testing Cloud Server (Windows) , authenticating AD users worked straight away.  I’m now testing a Cloud Server install on Ubuntu with a view to it being our production configuration.

    Using the NoMachine client software, I get the message ‘Authentication failed, please try again’ when trying to login with any Active Directory account.  The Ubuntu server has been added to the domain, and I can login to the server using AD accounts.  When entering the likes of wbinfo -u and wbinfo -g, I get the lists of users and groups from AD.

    I’ve been reading through some NoMachine forum posts and saw one that was very similar to our issue.  From reading that post, I ran the command:

    sudo /usr/NX/bin/nxexec –auth

    I then entered an AD username and the following was returned:

    nxexecPAMCheckCredentials: Error!  Account validation failed with error 6

    I guess this is what’s stopping it working?  Can anyone help me resolve this error?

    I’m running vanilla server and node config files, except ‘windows,physical-desktop’ being added to AvailableSessionTypes.

    Any help would be much appreciated. Thanks.

    Tom

    #28548
    AvatarCato
    Contributor

    Hello tom5,

    It’s possible that your problem is related to access control based on AD group policy. Please, check this article, which describes possible solution to your issue:

    https://www.nomachine.com/AR12P01007

    #28566
    Avatartom5
    Participant

    Hello Cato,

    That worked a treat!  Thank you very much.  Hope you have a great weekend.

    Tom

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.