Can’t use altgr in remote session

Forums / NoMachine for Linux / Can’t use altgr in remote session

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #30322
    Avatarboscard
    Participant

    Hi,

    First of all – awesome piece of software!

    I’ve noticed that I’m not able to use altgr in remote session. I’m from Poland and some of regional characters need to use altgr to type them. For example very common used ą – altgr+a.

    I can’t see any option related with altgr in configuration. Capture keyboard option also don’t help. My setup is two Debian 10 with KDE and Free NoMachine 6.12.3

    Any help will be appreciated 🙂

    #30324
    Avatarboscard
    Participant

    I’ve found that altgr key is treated as normal alt key – it tries to operate options from options bar. For example altgr+e acts as alt+e opening “Edit” menu in Firefox.

    #30344
    Avatargraywolf
    Moderator

    Hello. Try to change keyboard layout to PL in KDE settings on the remote host.

    You could also setup using the command line. Run a terminal on the remote desktop and type the command setxkbmap pl.

    #30345
    Avatarboscard
    Participant

    Thx graywolf – it works! It seems that NoMachine client is changing keybord layout. Do you know if I’m able to configure it somehow in NoMachine?

    #30356
    Avatargraywolf
    Moderator

    NoMachine does not try to change keyboard layout. Such problem occurs because display server didn’t initialize the virtual keyboard device (it does not depend on NoMachine). Setting layout in KDE should be enough to fix the problem permanently.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.