Caps-Ctrl Swap still a problem – TR07L04481

Forums / General Discussions / Caps-Ctrl Swap still a problem – TR07L04481

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #5837
    Avatariceback
    Participant

    I have 4.4.1 on two RHEL 6.6 machines and still see the problem.  And I was so hopeful. (I appreciate that it seems minor on the global scale but it seriously hampers my work.)

    #5846
    Avatargraywolf
    Moderator

    NoMachine detects the Ctrl/Caps swap reading the XKB properties on the client host. How did you swap the keys? If you did it with xmodmap NoMachine does not detect they are swapped. I’d prefer using setxkbmap in this way:

      setxkbmap -option ctrl:swapcaps

    You can check how that command affects the XKB properties:

    xprop -root | grep XKB

     

    #5851
    Avatariceback
    Participant

    Here’s the output from

    xprop -root | grep XKB
    _XKB_RULES_NAMES_BACKUP(STRING) = “evdev”, “pc105+inet”, “us”, “”, “terminate:ctrl_alt_bksp”
    _XKB_RULES_NAMES(STRING)        = “evdev”, “pc105+inet”, “us”, “”, “terminate:ctrl_alt_bksp,ctrl:swapcaps”

    #5850
    Avatariceback
    Participant

    I’m on RHEL6.6 using Gnome window manager. I use

    System->Preferences->Keyboard->Layouts to swap the keys. Is that not a front to setxkbmap?

     

    #5864
    Avatariceback
    Participant

    I also still see the problem from 32bit Ubuntu-12.4 running NoMachine-4.4.1. I too am running Gnome, CTRL swap from keyboard layout choices, same report xprop (i.e. ctrl:swapcaps)

     

    #5883
    Avatargraywolf
    Moderator

    I guess you are sharing the physical display. You need to add option ctrl:swapcaps to client as well as server host.

    Check also keycodes on both hosts:

    xmodmap -pke | grep -w “Control_L\|Caps_Lock\|37\|66”

    With keys swapped, Control_L has code 66 and Caps_lock has 37.

    Try also xev test tool to get more information.

    If nothing helps, please send client side logs to issues (at) nomachine (dot) com

    #5884
    Avatariceback
    Participant

    purity$ xmodmap -pke | grep -w Control_L
    keycode  66 = Control_L NoSymbol Control_L
    purity$ xmodmap -pke | grep -w Caps_Lock
    keycode  37 = Caps_Lock NoSymbol Caps_Lock
    purity$ /usr/NX/bin/nxserver –version
    NoMachine – Version 4.4.1

    quirky$ xmodmap -pke | grep Control_L
    keycode  66 = Control_L NoSymbol Control_L
    quirky$ xmodmap -pke | grep Caps_Lock
    keycode  37 = Caps_Lock NoSymbol Caps_Lock
    quirky$ /usr/NX/bin/nxserver –version
    NoMachine – Version 4.4.1

    xev (on purity) tells me

    KeyPress event, serial 33, synthetic NO, window 0x5a00001,
    root 0x298, subw 0x0, time 3008808426, (784,664), root:(794,756),
    state 0x2, keycode 37 (keysym 0xffe5, Caps_Lock), same_screen YES,
    XLookupString gives 0 bytes:
    XmbLookupString gives 0 bytes:
    XFilterEvent returns: False
    when I press the key labelled “Ctrl”. i.e. it is swapped, and

    KeyRelease event, serial 33, synthetic NO, window 0x5a00001,
    root 0x298, subw 0x0, time 3008788137, (784,664), root:(794,756),
    state 0x4, keycode 66 (keysym 0xffe3, Control_L), same_screen YES,
    XLookupString gives 0 bytes:
    XFilterEvent returns: False
    when I press the key labelled “Caps Lock”, again swapped as expected

    I just now connect from purity to quirky and indeed the “key labelled CapsLock” still toggles Upper Lower case and acts as a control key.  I’ll send the logfile(s).  I’m assuming they are the ones which named “quirky”.

    Has anyone reported success with this swapping?

     

    #5888
    Avatargraywolf
    Moderator

    I’ve just found something.

    The NoMachine client failed parsing your options field in the XKB configuration:

    “terminate:ctrl_alt_bksp,ctrl:swapcaps”

    In order to work around this issue, arrange the options so that ctrl:swapcaps becomes the first item:

    ctrl:swapcaps,terminate:ctrl_alt_bksp”

    This command (client side) will do the trick:

    setxkbmap -option “” -option “ctrl:swapcaps” -option “terminate:ctrl_alt_bksp

    #5894
    Avatariceback
    Participant

    YES! Bless you, that does the trick.  Is a little frightening how happy this makes me.

Viewing 9 posts - 1 through 9 (of 9 total)

This topic was marked as solved, you can't post.