CapsLock won’t turn off

Forums / NoMachine for Mac / CapsLock won’t turn off

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #41869
    nxmac
    Participant

    When I connect to my M1 Mac Mini using NoMachine from a Windows 10 client (I seldom connect any other way, so that may not be incredibly relevant), I often cannot turn CapsLock off after turning it on.  More specifically, all typing on the Mac through NoMachine will be CapsLocked even though I subsequently turned the function off on the client (light is out and typing on client applications is not capitalized).  Pressing Shift still returns capital letters in this scenario, so the only way I can even type without capitals is to disconnect and reconnect.  Fortunately, that does work, and I get expected case afterwards, but this seems like an odd problem to have fairly consistently across multiple versions.

    Regarding versions, I was actually going to post about this on November 22nd, but I noticed that my versions were significantly out of date, so I tried upgrading first and thought it resolved the issue based on a test.  Unfortunately, the issue has now recurred multiple times since then.

    Prior to updating, I had version 7.6.2_4 on the Windows client and the Mac host.  Since updating, I have been running 8.2.3_4 (x64) on the Windows client and 8.2.3_12 on the Mac host.  Is this sticky CapsLock behavior a known issue, or could it be an unknown bug that might need further investigation?

    #42041
    Britgirl
    Participant

    Hi, it would be useful to know what OS version you have on the M1.

    #42043
    nxmac
    Participant

    I am running Monterrey v12.6.1.

    #42369
    Britgirl
    Participant

    We have reproduced this same behaviour and will be opening a Trouble Report. When you are in session with enabled caps lock and then disable caps lock and move to another window (for example move from notepad to terminal ) caps lock will be locked.

    A temporary workaround can be clicking outside of session and then proceed with disabling caps lock.

    #42401
    fra81
    Moderator

    Hi nxmac,

    to confirm the issue you are reporting is the same that was reproduced in our labs, please answer the questions below.

    Does the temporary workaround suggested by Britgirl work also in your case?

    And can you try to press Capslock twice when the issue occurs? Does this also help?

    #42426
    nxmac
    Participant

    I have tested the workaround and it works.  Thank you.

    I’m unsure what you mean by press it twice.  I’ve definitely pressed it multiple times and it never turns off regardless of whether or not it is off outside of the connection.  I was going out of my way to avoid pressing it outside of the NoMachine screen because of a separate issue in separate software.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.