Client GPU at 100%, machine becomes unresponsive

Forums / NoMachine for Windows / Client GPU at 100%, machine becomes unresponsive

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #29758
    Avataram312
    Participant

    On my Windows client, task manager often shows nxplayer.bin GPU at 100% (see pic) and the machine gets very unresponsive.  Closing the NoMachine client brings GPU back near 0% and machine responds fine then.  This 100% GPU state can happen when the connected NoMachine session is idle.  The only change on the display then is the desktop’s tiny clock ticking.  Client CPU is approx 20%.  This condition does not always occur.  Sometimes  GPU is only about 60% and the client responds fine then.

    client: Win 10 on Lenovo P53s laptop, GPU0 Intel UHD Graphics 620 (maxes out), GPU1 Nvidia Quadro P520 (stays at 0%)

    server: CentOS 8 VM w/ICEWM virtual desktop on ESXi.  Hardware is HP gen10 server (no GPU) 24 core Xeon.  NoMachine 6.12.3_7.  Server CPU usage is low.

    Why does does the GPU hop up to 100% for long periods?

    Can I tell NoMachine to use my laptop’s GPU1 instead?  it appears to be just chilling there, waiting for some work.

    Attachments:
    #29781
    Avatarfisherman
    Moderator

    Can you try to disable “multi-pass encoding” in session Display Settings of NoMachine Menu Panel. https://www.nomachine.com/DT04O00140#5.1

    #29791
    Avataram312
    Participant

    That does appear to have fixed it so far.

    It would be great if there was a more perm fix so that running the default client settings don’t make the machine unusable.

    Thanks!

     

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.