Client session file is full of “Can’t read netlink result from kernel.” lines

Forums / NoMachine for Linux / Client session file is full of “Can’t read netlink result from kernel.” lines

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #35066
    lhorner
    Participant

    I am running:

     

    Server: 64bit Ubuntu 20, NoMachine 7.6.2

    Client: 64bit Ubuntu 18, NoMachine 7.6.2

    After setting up and using NoMachine for a few days the hard drive of the client machine was at 100%.  The culprit was a 75GB session file under the .nx directory full of lines:

    6272 6277 14:16:54 165.060 Socket: ERROR! Error is 42 ‘No message of desired type’.

    6272 6277 14:16:54 165.278 Socket: ERROR! Can’t read netlink result from kernel.

    6272 6277 14:16:54 165.287 Socket: ERROR! Error is 42 ‘No message of desired type’.

    6272 6277 14:16:54 165.482 Socket: ERROR! Can’t read netlink result from kernel.

    6272 6277 14:16:54 165.490 Socket: ERROR! Error is 42 ‘No message of desired type’.

    6272 6277 14:16:54 165.691 Socket: ERROR! Can’t read netlink result from kernel.

    6272 6277 14:16:54 165.702 Socket: ERROR! Error is 42 ‘No message of desired type’.

    6272 6277 14:16:54 165.970 Socket: ERROR! Can’t read netlink result from kernel.

    6272 6277 14:16:54 165.981 Socket: ERROR! Error is 42 ‘No message of desired type’.

    6272 6277 14:16:54 166.249 Socket: ERROR! Can’t read netlink result from kernel.

    6272 6277 14:16:54 166.260 Socket: ERROR! Error is 42 ‘No message of desired type’.

     

    Any ideas what is going on here?

     

    #35099
    Britgirl
    Keymaster

    On the connecting device try disabling MDNS. You can do this by going to Settings / Player / Security and unchecking the box “Don’t show other computers on the local network”.

    #35103
    lhorner
    Participant

    Hello thank you for the response.  That box, and all other, was already unchecked.

    #35135
    Tor
    Contributor

    Hi. Apologies, the box should be CHECKED in order to disable mDNS. 😛 If you’ll no longer see that log when the box is checked then we’ll know who is printing it, but not why it is happening. Are you using a custom kernel or a particular configuration or system security enforcing software?

    #35196
    lhorner
    Participant

    OK I think that has fixed things.  I do not see a growing file any more.  I do not run a custom kernel.  I am not knowingly running any security software but this company owned hardware and IT have root access.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.