Client – set to snap to size vs resize desktop

Forums / General Discussions / Client – set to snap to size vs resize desktop

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #21934
    AvatarColeman
    Participant

    Hello,

    When I’m on a Windows machine using the NoMachine client, sometimes my client seems to switch into a mode where resizing the window resizes the desktop. It starts out however, if I resize to large, it snaps to the desktop size. This is the behavior I want, instead of the resize. But after a while (maybe after the local desktop locks/unlocks?), it seems to switch to where the remote desktop starts to scale or resize to the client window size. I’m not sure why it happens, but more importantly, I prefer the snap to the specified desktop size. How do I make it go back to that when once it decides to start scaling? Is restarting the client the only option? It seems weird to me that it starts doing this in an existing session.

    Server is a Ubuntu VM.

    Thank you!

    #21940
    Avatargraywolf
    Moderator

    Hello. I guess your client switched to mode “Resize remote screen”. Unlocking the desktop doesn’t look related. By the way, you can turn it off easily, without restarting the client: use the kystroke “Ctrl+Alt+0” to access the NoMachine menu, and unlock the button “Resize remote screen”. Also look at “Fit to window”.

    Attachments:
    #21951
    AvatarColeman
    Participant

    Thanks!

    I didn’t realize the button was a function toggle, I thought it was going to cause my remote to resize to my desktop.’

    I’m not sure what triggers it, I didn’t mean to imply I think the unlock triggers it.  I just notice that it only seems to happen after my screen has locked (although, I don’t think it happens every time).

     

    #21980
    Avatargraywolf
    Moderator

    Yes, those buttons are toggles for enabling and disabling. So toggling “Resize remote” helped.
    If the behaviour continues, we’d need to have specific steps and environment details in order to be able to try and reproduce it.

Viewing 4 posts - 1 through 4 (of 4 total)

This topic was marked as solved, you can't post.