Client window does not properly resize to cover monitor

Forums / NoMachine for Linux / Client window does not properly resize to cover monitor

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #13145
    Avatarmdear
    Participant

    I connect to NoMachine servers from my Windows 10 PC (Lenovo W541).

    I use Gnome as my window manager.

    I want to be able to maximize my client window to fit a variety of different monitor sizes and resolutions (hi-res laptop display, lower-res large portrait office monitor, lower-res large landscape office monitor).

    I am having no problems doing this when I connect to an Enterprise Server (running server version 4.5 with player 5.1.26) on the following system:

    > uname -a
    Linux  2.6.18-416.el5 #1 SMP Wed Oct 26 12:04:18 EDT 2016 x86_64 x86_64 x86_64 GNU/Linux
    > cat /etc/issue
    Red Hat Enterprise Linux Server release 5.6 (Tikanga)

    > gnome-session –version
    Gnome gnome-session 2.16.0

    However, on the following system, when I create a NoMachine session and connect from my windows PC, I cannot resize to the full monitor size on any of my monitors.  I’ve tried adjusting monitor resolution but when I drag the client window to the top of the monitor (effectively maximizing it), its size “snaps” down to a smaller size and will not resize to cover the entire monitor.   As I gradually expand the client window size, its size also “snaps” down to smaller sizes (running server 5.1.62.1 with player 5.1.26).

    I’m seeing this behavior with both the latest free and Enterprise server.

     

    > uname -a

    Linux  2.6.32-573.7.1.el6.x86_64 #1 SMP Thu Sep 10 13:42:16 EDT 2015 x86_64 x86_64 x86_64 GNU/Linux
    > cat /etc/issue
    Red Hat Enterprise Linux Workstation release 6.7 (Santiago)
    > gnome-session –version
    gnome-session 2.28.0

    I’d really appreciate any advice on how I can get this working on the newer server (since the older server is being retired soon).

    I have already compared the /usr/NX/etc/config.node files between the two machines but I don’t see any significant differences that would account for this behavior.

     

    Thanks.

    #13165
    AvatarTor
    Contributor

    Hi.
    The behaviour you’re describing looks correct if the client is not configured to resize the remote desktop, it keeps the original geometry and snaps the window to that size. If instead you’ve enabled the “Resize remote screen” option in the Display menu, then the remote desktop may not support the resolution you’re trying to set or the desktop environment is forcing its own resolution.

    This behavioural change may be due not only to different NoMachine versions, but also to different desktop environments used on those servers.

    Are those servers running in virtual machines? Can you please send the output of the command ‘xrandr -q’ executed in a terminal on both servers?

    #13167
    Avatarmdear
    Participant

    Output from the known-good server that is old and will soon be retired:

    ott-xdm2-n2:9> xrandr -q
    SZ:    Pixels          Physical       Refresh
    0   1920 x 1200   ( 488mm x 258mm )   60
    1    320 x 240    ( 488mm x 258mm )   60
    2    640 x 360    ( 488mm x 258mm )   60
    3    640 x 480    ( 488mm x 258mm )   60
    4    800 x 480    ( 488mm x 258mm )   60
    5    800 x 600    ( 488mm x 258mm )   60
    6   1024 x 600    ( 488mm x 258mm )   60
    7   1024 x 768    ( 488mm x 258mm )   60
    8   1152 x 864    ( 488mm x 258mm )   60
    9   1280 x 720    ( 488mm x 258mm )   60
    10  1280 x 800    ( 488mm x 258mm )   60
    11  1280 x 1024   ( 488mm x 258mm )   60
    12  1360 x 768    ( 488mm x 258mm )   60
    13  1440 x 900    ( 488mm x 258mm )   60
    14  1600 x 900    ( 488mm x 258mm )   60
    15  1600 x 1200   ( 488mm x 258mm )   60
    16  1680 x 1050   ( 488mm x 258mm )   60
    17  1920 x 1080   ( 488mm x 258mm )   60
    18  3000 x 1920   ( 488mm x 258mm )   60
    *19  1920 x 1017   ( 488mm x 258mm )  *60
    Current rotation – normal
    Current reflection – none
    Rotations possible – normal
    Reflections possible – none
    ott-xdm2-n2:10>

    Output from new server where I’m trying to install NoMachine server:

    nostg-ott-vm-8:54> xrandr -q
    Can’t open display nostg-ott-vm-8:0

     

    Obviously something significantly wrong has occurred in the server setup/configuration, but I’m not sure how to debug further.

    I’d appreciate some pointers, thanks.

     

    #13168
    Avatarmdear
    Participant

    Both the servers are running in virtual machines, and I have tried to select the “Resize remote screen” option but it does not maximize to my monitor.

    #13169
    Avatarmdear
    Participant

    I should mention that xrandr works on my new server in the following instance:

    setenv DISPLAY :0
    nostg-ott-vm-8:67> xrandr -q
    xrandr: Failed to get size of gamma for output default
    Screen 0: minimum 320 x 200, current 1280 x 960, maximum 1672 x 1254
    default connected 1280×960+0+0 0mm x 0mm
    1280×768       60.0      0.0
    1600×1200      85.0     75.0     70.0     65.0     60.0      0.0
    1400×1050      75.0     60.0      0.0
    1280×1024      85.0     75.0     60.0      0.0
    1280×960       85.0     60.0*     0.0
    1152×864       75.0      0.0
    1024×768       85.0     75.0     70.0     60.0      0.0
    832×624        75.0
    800×600        85.0     75.0     72.0     60.0     56.0      0.0
    640×480        85.0     75.0     73.0     60.0      0.0
    720×400        85.0
    640×400        85.0      0.0
    640×350        85.0
    320×240         0.0
    400×300         0.0
    512×384         0.0
    854×480         0.0
    1280×720        0.0
    1366×768        0.0
    1280×800        0.0
    1440×900        0.0
    720×480         0.0
    720×576         0.0
    320×200         0.0
    800×480         0.0
    1672×1254       0.0
    nostg-ott-vm-8:68> setenv DISPLAY nostg-ott-vm-8:0
    nostg-ott-vm-8:69> xrandr -q
    Can’t open display nostg-ott-vm-8:0

     

    An “arp nostg-ott-vm-8” command comes up with the correct IP address.

    #13176
    AvatarTor
    Contributor

    Hi. The list of available resolutions on the new server appears to have mixed or invalid refresh rates. Is the guest OS correctly configured (guest additions, VMWare tools, etc)?

    #13210
    Avatarmdear
    Participant

    I found an online article, but was still not able to get my NoMachine client window to maximize across my portrait monitor (1080×1920).

    Advice would be appreciated.

    http://unix.stackexchange.com/questions/227876/how-to-set-custom-resolution-using-xrandr-when-the-resolution-is-not-available-i

    > gtf 1080 1920 60

    # 1080×1920 @ 60.00 Hz (GTF) hsync: 119.22 kHz; pclk: 178.35 MHz
    Modeline “1080x1920_60.00”  178.35  1080 1168 1288 1496  1920 1921 1924 1987  -HSync +Vsync

    > xrandr –newmode “1080x1920_60.00”  178.35  1080 1168 1288 1496  1920 1921 1924 1987  -HSync +Vsync
    xrandr: Failed to get size of gamma for output default

    xrandr –addmode default “1080x1920_60.00”
    xrandr: Failed to get size of gamma for output default

    echo $DISPLAY
    :0

    xrandr -q
    xrandr: Failed to get size of gamma for output default
    Screen 0: minimum 320 x 200, current 1400 x 1050, maximum 1672 x 1920
    default connected 1400×1050+0+0 0mm x 0mm
    1280×768       60.0      0.0
    1600×1200      85.0     75.0     70.0     65.0     60.0      0.0
    1400×1050      75.0     60.0*     0.0
    1280×1024      85.0     75.0     60.0      0.0
    1280×960       85.0     60.0      0.0
    1152×864       75.0      0.0
    1024×768       85.0     75.0     70.0     60.0      0.0
    832×624        75.0
    800×600        85.0     75.0     72.0     60.0     56.0      0.0
    640×480        85.0     75.0     73.0     60.0      0.0
    720×400        85.0
    640×400        85.0      0.0
    640×350        85.0
    320×240         0.0
    400×300         0.0
    512×384         0.0
    854×480         0.0
    1280×720        0.0
    1366×768        0.0
    1280×800        0.0
    1440×900        0.0
    720×480         0.0
    720×576         0.0
    320×200         0.0
    800×480         0.0
    1672×1254       0.0
    1080x1920_60.00   60.0

    > xrandr –output default –mode “1080x1920_60.00”
    xrandr: Failed to get size of gamma for output default
    xrandr: Configure crtc 0 failed

     

    #13211
    Avatarmdear
    Participant

    OK, I found the issue.  In my Esxi5.1 hypervisor I was not assigning the RHEL6 VM enough video memory, I had assigned it 8MB, but for my monitor size it required 10MB.  Reporting this so other users having a similar problem won’t have to go through a month of pain like I just did.

    #13222
    AvatarBritgirl
    Keymaster

    Thanks for letting us know it was a configuration issue. I’ve added some tags to the forum post so others can find it.

Viewing 9 posts - 1 through 9 (of 9 total)

This topic was marked as solved, you can't post.