Client window stops updating after 10mins?

Forums / NoMachine for Linux / Client window stops updating after 10mins?

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #25161
    Avatarcharlesc
    Participant

    I’m running into an issue for which I haven’t been able to find related posts or topics.  Appreciate any info.

    I run NoMachine server on an OSX machine, and the client/player on a Linux desktop.  I have programs running on the OSX desktop that I have to monitor, but which I don’t have to actually interact with for periods of time – i.e. web pages that update displayed info without user clicks, or new messages that show up in the Slack app etc.  I frequently am using another app on my Linux machine while keeping an eye on these programs running on the OSX machine through the NoMachine connection.

    But after a period of not interacting with the NX client window – not clicking on it, appears to be for 10 minutes – the NoMachine window stops updating.  The programs are still running on the OSX machine and appear to be working normally, but the updates to the display stop happening until I click on the NoMachine window, at which point all the updates come through.  So essentially the remote desktop “freezes” after ten minutes and doesn’t unfreeze until I click in the NoMachine window.  So I stop seeing my updates from these apps.

    The fact that this happens after what appears to be ten minutes makes it look to me like a timeout, but I haven’t found any info about changing or disabling it.

    I’m running 6.8.1 on the OSX server.  I tried 6.8.2 and saw no difference in behaviour, though it appeared to introduce another bug, so I have reverted to 6.8.1.  Client on Linux is also 6.8.1.

    Easiest way to reproduce this is to open a browser in the remote desktop session, displaying an animated GIF.  Then select another application and don’t click on the NoMachine window.  After 10 minutes, the GIF stops animating until the NoMachine window is clicked within the desktop area, then the animation restarts.

    Server: NoMachine 6.8.1 (free version) on OSX Mojave 10.14.6 64-bit
    Client: NoMachine 6.8.1-1 (free version) on Debian Linux 10/buster x86_64

    Thanks,

    Charles

    #25174
    Avatarkroy
    Contributor

    Do you have enabled “Prevent computer from sleeping automatically when the display is off” in the Mac Energy Saver settings? It looks like your computer is set to sleep after 10 minutes. To avoid this enable that option.

    Attachments:
    #25179
    Avatarcharlesc
    Participant

    TL;DR I have an apparent fix for the problem now.  See below.

    The Mac was not sleeping; it was already set to never sleep, and I continued to have live SSH sessions to it, and interactions with other network services running on it.  Just the NoMachine remote desktop session stopped updating.

    When double-checking the energy-saver preferences to verify I had disabled sleeping, I noticed the “turn off display” was set to 10 minutes, and it doesn’t appear to be a coincidence.  I already had the NoMachine server prefs set to blank the screen when a remote client connected, so whether the screen was on or off didn’t matter to me (and it isn’t obvious now whether NoMachine is actually turning the display off with the backlight powered down, or just blanking it).

    But setting the system preference “turn off display” to “never” appears to correct the problem for me.  I’m guessing the Mac powers down the GPU along with the screen, and the video memory stops updating, so the NoMachine server can no longer tell anything’s going on.

    Thanks!

    Charles

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.