Clipboard in “View Only” Virtual Desktop copied from shadowing session

Forums / NoMachine Terminal Server Products / Clipboard in “View Only” Virtual Desktop copied from shadowing session

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #26365
    Avatarriek
    Participant

    When connected to a virtual display as trusted user in shadowing  mode (VirtualDesktopMode “view only” set), the clipboard from the shadowing user overwrites the clipboard of the interactive user. Is this a bug, a feature or have we misconfigured the server.cfg? I would expect the clipboard to be disabled when using VirtualDesktopMode = 0.

    We use these setting:

    VirtualDesktopMode: 0

    EnableClipboard: client

     

    Product: NoMachine Terminal Server Evaluation – Version 6.9.2

    OS: Debian 10, Desktop Mate

    Client OS: Windows 10

    #26419
    Avatarfra81
    Moderator

    Hi,

    I think you make a good point about disabling clipboard in ViewOnly mode. However you can already avoid that by setting ‘server’ or ‘none’ in the EnableClipboard key.

    # client: The content copied on the client can be pasted inside the
    #         NX session.
    #
    # server: The content copied inside the NX session can be pasted
    #         on the client.
    #
    # both:   The copy&paste operations are allowed between both the
    #         client and the NX session and vice versa.
    #
    # none:   The copy&paste operations between the client and the NX
    #         session are never allowed.

    #26644
    Avatarriek
    Participant

    Thank you, we are using “none” as workaround now.

    Perhaps this could still be corrected in a future update.

Viewing 3 posts - 1 through 3 (of 3 total)

This topic was marked as solved, you can't post.