Clipboard pastes non-English characters as unicode

Forums / NoMachine for Linux / Clipboard pastes non-English characters as unicode

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #8267
    unlim
    Participant

    When I copy (within NX) some non-English symbols and trying to paste them on host OS – then symbols converted to Unicode.

    Example:

    проблема -> \u043f\u0440\u043e\u0431\u043b\u0435\u043c\u0430

    How to fix this?

     

    (version 4.6.16 both sides)

    #8342
    graywolf
    Moderator

    Hello unlim.

    Could you provide details about the operating systems on the both sides and whether the problem arises connecting to a physical or a virtual display?

    #8346
    unlim
    Participant

    I use Win7-Win10 as host OS and CentOS 5x-6x as client OS.

    Client OS are remote only – no physical access.

    #8361
    graywolf
    Moderator

    I tried to reproduce without success.

    Could you tell me how do you access the remote clients, through NoMachine as well?

    What is the application you copy from and the one you paste to?

    #8372
    unlim
    Participant

    Yes, I’ve use both NX 3x and NX 4x clients to connect to my remote OS.
    Problem happens when I copy on my remote OS and paste on my host OS.

    Problem happens for all nonEnglish characters.

    #8377
    unlim
    Participant

    In addition: application does not reall matter, I use different…

    #8391
    graywolf
    Moderator

    I see this problem with this setup:

    Client NX 3.5 for Windows -> Server 4.6.16 for Linux (Centos 6.5).

    NX 3.5 cannot copy/paste non-latin charachters, but I didn’t find any issue copying from/to Linux and Windows when both sides run NoMachine 4.6.

    Plase try running NoMachine 4 on both sides, don’t mix-up NX 3 and NoMachine 4. If this won’t solve your problem, please send relevant log files to forum (at) nomachine (dot) com

    With “relevant log” I mean:

    • /usr/NX/var/log and $HOME/.nx  on Linux
    • %ProgramData%\NoMachine\var\log and  %USERPROFILE%\.nx on Windows

    Please gather logs with troublesome session running and connected.

     

    #8423
    unlim
    Participant

    Seems that’s right – NX 4x server/client has no such problem, only 3x server.

    Is it possible to tune 3x server?

    Or can I migrate from 3x server to 4x server w/o server machine content/functionality/data lost?

    #8428
    Britgirl
    Keymaster

    Any questions and issues concerning NX 3.5.0 must be directed to the appropriate website channel. In this case, if you’re a customer with a valid subscription, that’s the customer area. If you are using a free product or an expired subscription, please go to the footer of the website, click Contact Us and select General Enquiries.

    The forums are entirely dedicated to NoMachine 4 and later. I recommend you try Workstation from the Terminal Server range with version 4 client (Enterprise Client or the free NoMachine package). If your problem persists, we can deal with the investigation appropriately as Graywolf mentioned.

Viewing 9 posts - 1 through 9 (of 9 total)

This topic was marked as solved, you can't post.