Configuration error on Ubuntu 16 NX Server

Forums / NoMachine for Linux / Configuration error on Ubuntu 16 NX Server

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #25911
    ceduarte1
    Participant

    I’m running NXServer 6.4.6 on Ubuntu 16.04.5 LTS. I’m connecting using NXClient on Windows.

    I’m currently getting Configuration Error when I connect. I followed the advice from a previous post and set the following in /usr/NX/etc/server.cfg:

    SessionLogLevel 7

    and have uploaded the logs.

    [ceduarte@wkstn-ceduarte]~ $ dpkg -l ubuntu-desktop

    Desired=Unknown/Install/Remove/Purge/Hold

    | Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend

    |/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)

    ||/ Name           Version      Architecture Description

    +++-==============-============-============-=================================

    ii  ubuntu-desktop 1.361.2      amd64        The Ubuntu desktop system

    [ceduarte@wkstn-ceduarte]~ $ ps -ef | grep -i xor | grep -v grep

    root      2197  2165  1 09:55 tty7     00:05:46 /usr/lib/xorg/Xorg -core :0 -seat seat0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch

    [ceduarte@wkstn-ceduarte]~ $ ls -l /etc/X11/Xsession

    -rwxr-xr-x 1 root root 3730 May  3  2017 /etc/X11/Xsession

    [ceduarte@wkstn-ceduarte]~ $ ps ax | grep nx

    1155 ?        Ssl    0:01 /usr/NX/bin/nxserver.bin –daemon

    2787 ?        Sl     0:00 /usr/NX/bin/nxd

    16477 ?        Sl     0:00 /usr/NX/bin/nxclient.bin –admin

     

    #25920
    Britgirl
    Keymaster

    I am not sure which topic you are referring to, another Ubuntu topic?

    The logs were too big to attach successfully, so make sure send them to forum[at]nomachine[dot]com making sure you use the title of your topic as the subject.

    Thanks!

     

    #25946
    ceduarte1
    Participant

    The previous issue I was referring to was:

    forums.nomachine.com/topic/error-is-134-protocol-error-ubuntu

    I’ve sent the logs as email attachment.

    Thanks,

    -Carlos.

    #26002
    Britgirl
    Keymaster

    logs received, but please check the version of NoMachine client you have installed.

    #26009
    ceduarte1
    Participant

    NoMachine Client version is: WinNT 6.4.6

    [ceduarte@wkstn-ceduarte]~ $ sudo /etc/NX/nxserver –history –client-platform –client-type –client-version | tail -4

    1002    ceduarte 10.252.34.155  7A43E48AA701DA7E6CF2B46518188750 2020-02-20 23:19:59 Finished localhost:4000 physical-desktop      GUI         6.4.6          winnt

    1002    ceduarte 10.252.67.41   2139C99116BD5542F3172D2E8B63D351 2020-02-19 09:55:58 Finished localhost:4000 physical-desktop      GUI         6.4.6          winnt

    1002    ceduarte 10.252.26.186  C3F453F115F5C46C8AC9D5F3E2FFC15C 2020-02-18 22:07:27 Finished localhost:4000 physical-desktop      GUI         6.4.6          winnt

     

    #26058
    ceduarte1
    Participant

    I rebooted the Ubuntu server machine (for a a second time) and the problem has disappeared.

Viewing 6 posts - 1 through 6 (of 6 total)

This topic was marked as solved, you can't post.