Configure NX to connect to desktop manager in display :1?

Forums / NoMachine for Linux / Configure NX to connect to desktop manager in display :1?

Tagged: 

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #4155
    AvatarJugdish
    Participant

    Hi, I am running nxserver 4.0.370 (free edition) with Ubuntu 14.04 LTS. The machine is a dedicated HTPC, connected to my TV using an HDMI cable, and so DISPLAY :0 is preoccupied with an always-running instance of XBMC to watch media on the TV.

    However, I would still like to remote desktop into this box and be presented with a desktop manager, without disrupting XBMC.

    I am by no means an expert regarding X11, display managers, window managers, and so on. My rudimentary understanding is that I will need to set up NoMachine to connect using DISPLAY :1. But do I need to use a virtual desktop manager like Xvfb to accomplish this, or can the instance of X server that is hosting XBMC on DISPLAY :0 also be used to host the desktop manager that NoMachine connects to on DISPLAY :1?

    How do I go about configuring my nx server/client to connect using DISPLAY :1 by default?

    Many thanks for any help!

    #4176
    Avatarreza
    Moderator

    You can run X server on DISPLAY :1 and start on it whatever you like (Gnome, KDE).
    There is no need to use Xvfb in that case.
    Remember to adjust ‘DisplayDefault’ key in node.cfg to ‘1’

    #4179
    AvatarJugdish
    Participant

    Hi, thanks for your reply. So would this be a second instance of the X server used for DISPLAY :1 ?

    At the moment my machine boots up in console mode, and I have an upstart script which launches XBMC via xinit. So the X server is started just for the XBMC process. To start a DM in DISPLAY :1 would this also be done via xinit, or can I somehow re-use the same X session that was spawned for XBMC?

    #4187
    Avatarreza
    Moderator

    How to start secondary X server is explained in multiple articles, please take a look for example at these:

    How To Run Multiple X Sessions Without Virtualization


    http://ubuntuforums.org/showthread.php?t=213756

    #4205
    AvatarJugdish
    Participant

    Perfect, those are exactly the kind of links I was after, thanks very much for your help!

    #4225
    AvatarJugdish
    Participant

    Hi, I’ve followed the instructions given, but I receive this error when trying to connect from another machine:

    <No available sessions on this server>
    The server was unable to make the local display available or access to the local display is disabled.

    I have started a second X server on display :1 and I am running Xfce4 window manager on that display. When I hit Ctrl+Alt+F8 on the server, I see Xfce4 running fine.

    I’ve also updated /usr/NX/etc/node.cfg to add the following line at the bottom:

    DisplayDefault :1

    (I should note that “DisplayDefault” was not among any of the keys listed in that file, and as far as I can tell is completely undocumented.)

    I then restarted nxserver. So now here are all the relevant processes currently running:

    1204 ? Ss 0:00 xinit startxfce4 — :1 vt8
    1210 tty8 Ss+ 0:25 X :1 vt8
    1549 ? S 0:00 xterm -geometry +1+1 -n login startxfce4
    1556 pts/1 Ss+ 0:00 /bin/sh /etc/xdg/xfce4/xinitrc — /etc/X11/xinit/xserverrc
    1577 pts/1 Sl+ 0:00 xfce4-session
    1617 pts/1 S+ 0:00 xfwm4
    2026 ? Sl 0:01 /usr/NX/bin/nxserver.bin root 1543 –startup
    2047 ? Sl 0:00 /usr/NX/bin/nxd
    2567 ? Sl 0:03 /usr/NX/bin/nxserver.bin -c /etc/NX/nxserver –login -H 6
    25414 ? Sl 0:00 /usr/NX/bin/nxserver.bin –localsession

    …and yet I cannot connect from another machine. Any ideas?

    #4242
    Avatarreza
    Moderator

    Please update to newest version (4.2.26).
    Key DisplayDefault was introduced recently.

    #4356
    AvatarJugdish
    Participant

    Ok, I’ve made progress, but still not working correctly. I upgraded nxserver to the latest version, so it now recognises the DisplayDefault key. I can now remote connect to my server using NoMachine, and I no longer receive the “No available sessions on this server” error message.

    Instead, I am presented with a black screen. This seems to be tied to the XBMC instance running in full screen on DISPLAY :0. If I ssh into the server and kill the XBMC process, suddenly the remote NX window flashes and jumps to DISPLAY :1 where I am greeted with the Xfce4 desktop running there.

    The question is, why is the XBMC process interfering with the NX window if it’s running in DISPLAY :0 and NX is supposed to be connecting to DISPLAY :1 ?

    #4372
    Avatarasko
    Participant

    hi , i have a similar setup with xbmcbuntu, however i have another question, when i connect remotely to either xbmc or xbmcbuntu i connect fine, but if i exit xbmc to log off and on to xbmcbuntu i lose the connection and can not connect again … any help please

    #4566
    Avatarreza
    Moderator

    Hi Jugdish,

    I’m sorry for misleading.

    If you have two X servers, one on display 0 and second on display 1,

    only one from them can be active.

    To activate the second you have to switch virtual terminal.

    #4727
    Avatarroylefamily
    Participant

    If you have two X servers, one on display 0 and second on display 1, only one from them can be active.

    To activate the second you have to switch virtual terminal. Does this mean that what Jugdish wanted to achieve is not possible? I want to do the same thing.

    #5230
    AvatarBritgirl
    Keymaster

    It’s possible by switching the virtual terminal from keyboard connected to the machine or remotely with help of chvt command line tool. Alternatively you can use a Xvfb for a secondary display.

    Another solution is to use the Workstation edition from our virtual Linux desktop range of products.

Viewing 12 posts - 1 through 12 (of 12 total)

This topic was marked as solved, you can't post.