Configure Windows Client for UK keyboard

Forums / NoMachine for Windows / Configure Windows Client for UK keyboard

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #8884
    trevorjharris
    Participant

    I am running Windows client 5.0.47. Please can some one tell me how to configure it for a uk keyboard. It currently maps as a US keyboard.

    #8891
    graywolf
    Moderator

    Client simply gets the keyboard currently set in the local system. It is possible you need to change keyboard layout in the desktop you are reaching from remote. Could you describe the actions that made you notice keyboard wasn’t correct?

    #8896
    trevorjharris
    Participant

    When typing into the local client on windows the mapping is correct.

    When I type into a remote desktop it thinks it is a US keyboard. eg if I type \ it is displayed as <. I think I need to configure the server keyboard.

    #8900
    trevorjharris
    Participant

    I have investigated a bit more. I understand that in recent versions of NoMachine the client sends raw key codes to the server and relies on nxserver to do the mapping. If I run setxkbmap I get the correct mapping but if I close the session and login again the key mapping reverts to a US keyboard. I need nxserver to start with the UK mapping. I have tried all the usual methods without success. The nxserver is running on Raspberry pi Debian so this is really a linux problem.

    #8919
    graywolf
    Moderator

    Could you confirm that you are running NoMachine version 4 or 5 as a server?

    Did the problem arise connecting to a physical display?

    I think you have to set the keyboard layout in the remote desktop environment. In Gnome the configuration is somewhere under “System”, “Preferences”, “Keyboard”, tab: “Layout”, precise location depending on version.

     

    Attachments:
    #8924
    trevorjharris
    Participant

    I am running NoMachine_5.0.47_2_armv6hf.deb on the raspberry pi. If I run “setxkbmap -layout gb” I get the correct mapping but only for one session. The normal way to configure the keyboard is to add a keyboard entry to xorg.conf or xorg.conf.d. I tried this with the files in various places but without success. NoMachine’s files are in the /usr/NX directory. nxserver does not seem to support xorg.conf. This actually is a linux problem as the windows client now sends raw keyboard events to the server without any mapping.

    #8935
    graywolf
    Moderator

    It seems the right way for settng keyboard on that distro is the command

    dpkg-reconfigure keyboard-configuration

    Let me know if it helps.

    #8942
    trevorjharris
    Participant

    Unfortunatly that did not work. I think reason is that dpkg… will reconfigure the raspberry pi xserver where as nx is running its own xserver called nxserver. I need to configure nxserver. Thanks for your help.

     

     

    #8950
    graywolf
    Moderator

    Could you attach folder /usr/NX/var/log from the Raspberry server?

Viewing 9 posts - 1 through 9 (of 9 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.