Connect multiple sessions to same virtual desktop

Forums / General Discussions / Connect multiple sessions to same virtual desktop

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #38255
    mehargags
    Participant

    I installed Workstation eval version on Debian 11, can access 4 different Virtual Desktops but if I try to connect second session to the ‘same’ virtual desktop, the first one closes. The ‘Desktop not shared’ is greyed out, I don’t seem to have the ability to enable disable. It should not be this hard, what am I missing?

    Do I need Enterprise version of client to connect or something?

    I’m connecting from Mac and Windows machines.

    #38261
    Britgirl
    Keymaster

    Do I need Enterprise version of client to connect or something?

    No you don’t.

     

    but if I try to connect second session to the ‘same’ virtual desktop, the first one closes.

    This sounds like you’re migrating the session. Session migration is on by default in Terminal Server products. When you use the same account to start a second virtual desktop session and the first is still open, NoMachine assumes by default that the connecting user is also the same and performs the automatic migration of the session from one device to the other.

    To disable automigration, see this forum topic https://forums.nomachine.com/topic/unable-to-start-multiple-sessions-using-same-user#post-12351.

    Further tips are also available here:

    How to share a NoMachine virtual Linux desktop with other users
    https://knowledgebase.nomachine.com/AR07P00993

    With regards to the ability to toggle the Desktop Shared icon, this looks like a separate issue. To begin with, tell me whether the tips above help with the first question.

     

    #38269
    mehargags
    Participant

    Thanks @Britgirl for the link.

    I did have ‘automigrate=0’ in server.cfg before but that alone did not help. I pasted the exact line
    ConnectPolicy autocreate=1,autoconnect=1,automigrate=0,desktop=0,dialog=0

    and now the second session connects well… however, only read-only mode. I can’t click or do any action on the second session connected to the virtual desktop.

    I’d also like the full access on second or third user connected to  same virtual desktop session using HTTP so please tell me what config changes would allow that

    Thanks

    #38299
    Britgirl
    Keymaster

    and now the second session connects well… however, only read-only mode. I can’t click or do any action on the second session connected to the virtual desktop.

    Do you mean that ‘user 2’ connects to the same desktop as ‘user 1’ but user 2 is is read-only mode? Did you user 1, the owner, accept the connection in interactive mode? (as explained in the article above https://knowledgebase.nomachine.com/AR07P00993)

    Or do you mean that ‘user 2’ can connect to their own virtual desktop but it is in read-only mode?

    #38303
    mehargags
    Participant

    No, I’m connecting 2 different sessions with same user to the same virtual desktop.

    ‘User1’ is running a desktop ‘U1D1’
    I want another ‘person’ to connect 2nd session with same ‘User1’ to the same virtual desktop U1D1 in full collaborative mode. Is it possible or does he have to be another user2, user3 ?

    No, there is no accept connection or any such prompt.

    #38312
    Britgirl
    Keymaster

    User1’ is running a desktop ‘U1D1’
    I want another ‘person’ to connect 2nd session with same ‘User1’ to the same virtual desktop U1D1 in full collaborative mode. Is it possible or does he have to be another user2, user3 ?

    Thanks for clarifying. Yes, it is possible, you don’t need a second username to be able to connect and interact. Once session migration has been disabled, this is the way it works. We checked on the fly just to make sure that Workstation for Debian is working out of the box, which it is. The only setting we changed is the automigrate key. To enforce it, you can remove the #. So we have in server.cfg

    ConnectPolicy autocreate=1,autoconnect=1,automigrate=0,desktop=0,dialog=0,xsessions=0,udp=1

    We were able to connect to the same desktop in two separate sessions as the same user and both users can interact. Maybe you inadvertently changed something else in the server.cfg file?

    Check this key in the server.cfg: ‘VirtualDesktopMode’ ? It should be set to 2, which is the default setting.

    If that does not work, send us your server.cfg so we can take a look.

    #38314
    mehargags
    Participant

    Yeah it is possible I tinkered way too much than needed lol

    Server.cfg

    ConfigFileVersion 4.0
    EnableUPnP NX
    EnablePasswordDB 0
    ConnectPolicy autocreate=1,autoconnect=1,automigrate=0,desktop=0,dialog=0
    ClientConnectionMethods NX,SSH,HTTP
    SSHAuthorizedKeys authorized_keys
    VirtualDesktopMode 0
    VirtualDesktopAuthorization 1
    PhysicalDesktopMode 0
    PhysicalDesktopAuthorization 1
    AvailableSessionTypes unix-remote,unix-console,unix-default,unix-application,physical-desktop,shadow,unix-xsession-default,unix-xdm
    WebReferrer “”
    WebRedirect “”
    Section “Server”
    Name “Connection to localhost”
    Host 127.0.0.1
    Protocol NX
    Port 4000
    Authentication password
    EndSection

    I think I might have tinkered node.cfg too

    ConfigFileVersion 4.0
    DefaultDesktopCommand “/usr/bin/lxsession -e LXDE”
    AvailableSessionTypes unix-remote,unix-console,unix-default,unix-application,physical-desktop,shadow,unix-xsession-default,unix-xdm
    EnableSmartcardSharing 1
    AudioInterface disabled
    EnableCUPSSupport 1
    CUPSBinPath /usr/bin
    CUPSSbinPath /usr/sbin
    CUPSBackendPath /usr/lib/cups/backend
    EnableSMBFSSupport 0
    CommandFuser /usr/bin/fuser
    CommandLsof /usr/bin/lsof
    CommandXdpyInfo /usr/bin/xdpyinfo
    CommandXmodmap /usr/bin/xmodmap
    CommandXkbComp /usr/bin/xkbcomp
    DefaultXSession “/etc/X11/Xsession default”
    ClientConnectionMethods NX,SSH
    DisplayServerThreads auto
    DisplayEncoderThreads auto
    EnableDirectXSupport 0
    DefaultConsole xterm
    EnableDbusLaunch 1

    #38321
    Britgirl
    Keymaster

    In the meantime change VirtualDesktopMode 0 -> VirtualDesktopMode 2 as per my previous suggestion. I also noticed you’ve changed PhysicalDesktopMode to 0. Setting it to 0 means that access is in view-only. So change:

    VirtualDesktopMode 0 -> VirtualDesktopMode 2 and

    PhysicalDesktopMode 0 -> PhysicalDesktopMode 2

     

Viewing 8 posts - 1 through 8 (of 8 total)

This topic was marked as solved, you can't post.