Connect to Localhost

Forums / NoMachine for Mac / Connect to Localhost

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #3335
    indolering
    Participant

    So, I’m trying to hack a sandbox without having to run a full-blown virtual machine.

    I got clever and created a sandboxed user, installed NoMachine, and switched over to my admin account and tried to connect to the sandboxed account.  Using the NoMachine protocol, it streamed the admin users screen, it looked like my screen had been stuck between two mirrors.

    So, I tried switching the connection to using SSH but now the password gets rejected.  I can login via SSH in the terminal and I’ve given it all the permissions.

    I was able to connect to myself using VNC, but it was very slow.

    #3360
    Britgirl
    Keymaster

    It sounds like you need to change the display of the X server which is shared by NoMachine. If you want to set a different display (the x server owned by your sandbox), change the node.cfg key: #DisplayDefault :0 by replacing the ’0′ with the correct number. Not sure if you’ve seen this:

    https://www.nomachine.com/AR10K00710

     

    #3385
    indolering
    Participant

    Ahh, well, I am running OS X, not X.  I’m not sure if that makes any difference.

    #3398
    Britgirl
    Keymaster

    Yes, it does matter. My apologies, I completely missed that you had submitted this request to the Mac forum. My answer wrongly assumed you were connecting to Linux.
    Can you give us more details about the sandbox you created? Also, are you trying to start the desktop via fast-user switch or are you already logged on?

    #3444
    indolering
    Participant

    I’ve got the sandboxed account locked down pretty tight, but I think I tried doing this with a normal user account.  I can retry if you think it’s worth doing.

    Does this require admin privileges?  What else might be affecting it?  I would obviously like to keep this as locked down as possible.

    I’m not sure what you mean by “already logged on” – I used fast user switching to log into the account and enable NoMachine ….

    #3453
    reza
    Moderator

    With NoMachine for Mac it’s not possible to have two users connect to a remote host: one on the physical console and another via NoMachine.

    This is because NoMachine doesn’t currently support virtual sessions on Mac. It’s not related to how you’ve set up your sandbox. There are things that are trivial to do on Linux that are not as easy on OSX, especially when you are dealing with an OS where what you can do and what you cannot do is written in the EULA. But it is definitely something we would like to have as a feature in the future.

    #3465
    indolering
    Participant

    Yeah, Apple has a very irritating policies towards people using their operating system, this isn’t the first time I’ve bumped my head up against it!  Thanks Reza!

Viewing 7 posts - 1 through 7 (of 7 total)

This topic was marked as solved, you can't post.