Connect to physical display

Forums / NoMachine for Linux / Connect to physical display

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #13289
    walttheboss
    Participant

    Local and Remote on same LAN: Kubuntu 16.04.1 and NoMachine 5.1.6.2

    When I connect from my machine to one on the network I get a virtual display.  I want to reach the main screen so my client can see what I am doing. It worked well and then one time it asked me if I wanted to create a virtual display.  I said yes because the remote machine’s monitor was not turned on.  Since then I cannot get to the physical display from any machine.

    How do I reset this setting so that I can connect to the physical display?

     

    Local and Remote: Kubuntu 16.04.1 with NoMachine 5.1.62

    Please help.

     

    #13325
    graywolf
    Moderator

    I think the virtual display is retained. Restarting the NoMachine server is the simpler thing you can do, use this command:

    sudo /usr/NX/bin/nxserver –restart

     

    #13337
    walttheboss
    Participant

    Will check this AM.  I have restarted, rebooted, reinstalled many times.  Do you know of anywhere in KDE where the virtual display config is saved?

    #13338
    walttheboss
    Participant

    Thanks @graywolf for the comment.  Good to know that command. Restarting the nx server however did not solve the problem.

    I went into the two config files /usr/NX/etc/node.cfg and server.cfg.

    server.cfg had added two lines because of the one time that I connected with the monitor off.

    Lines 920 to 950.  Maybe slightly off depending on your version.  Only a few lines shown. I commented out the bold lines below and all is working well.  When I connect to that computer it gives me the actual display. For some reason once this is set there is no GUI way to reverse it.  You need to go in and change the config files back.

    # 1: Enabled. NoMachine will create automatically the new display at
    #    server startup. This setting has to be used in conjunction with
    #    ‘DisplayOwner’ and ‘DisplayGeometry’.
    #
    # 0: Disabled. NoMachine will prompt the user for creating the new
    #    display. This is the default.
    #
    #CreateDisplay 0
    #
    #
    #DisplayOwner “”
    DisplayOwner claw
    #
    # When ‘CreateDisplay’ is enabled, specify the resolution of the new
    CreateDisplay 1
    # desktop in the WxH format. Default is 800×600.
    #
    #DisplayGeometry 800×600
    DisplayGeometry 800×600

    #13341
    walttheboss
    Participant

    One more change.  Make sure that you also check your node.cfg .  It could be that the Physical Display variable is now set to a virtual and not actual display.  When you start the machine and the NoMachine icon does not appear in the System Tray then node.cfg has been messed up.

    /usr/NX/etc/node.cfg

    Look around line 825.

    Make sure that the line either refers to your actual physical display or is commented out(Default).

    To know what display is the real one that normal users use you need to be on that computer.  Open a terminal and type $DISPLAY

    It will return something like :0 or :1

    If you then want to specify this then do so in node.cfg.

    #13357
    graywolf
    Moderator

    walttheboss, it is true that if you checked “Always create a new display on this server”  it cannot be reverted through any GUI.

    But on server restart, if a working physical display is found NoMachine doesn’t start the virtual display and connection to physical is allowed, no matter if you checked “Always create” or not.

    In your case, PhysicalDisplays in node.cfg played a role: no X server was found with the specified display number, so NoMachine started the virtual display and assumed all connection are directed to virtual. As you stated correctly, the PhysicalDisplays line in node.cfg should be left commented out.

     

Viewing 6 posts - 1 through 6 (of 6 total)

This topic was marked as solved, you can't post.