Connect to Windows 10 without password

Forums / NoMachine for Windows / Connect to Windows 10 without password

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #42319
    Marc Delpont
    Participant

    Hi,

    I run a VR arcade location with several Windows 10 VR stations that are started with a passwordless account.
    I would like to use NoMachine to connect on the LAN to share the VR stations screens on my operator station, but I can’t find how to connect without a password. How can I do that ?

    Thanks for helping.

    Marc

    #42378
    Britgirl
    Participant

    Hi, NoMachine uses a system user that is already created on the server side (System username and password). While it is common on Windows not to set a password, one must be set if someone wants to use NoMachine. This is due to Windows policies. A local system account is limited to using an empty password to console logon only.

    You can find more about this subject in the following article : https://knowledgebase.nomachine.com/AR05L00802

    “Due to Windows policies, a local system account is limited to using an empty password to console logon only. This is a security setting within the Windows OS and determines whether local accounts that are not password protected can be used to log on from locations other than the physical computer console. If enabled, local accounts that are not password protected will only be able to log on at the computer’s keyboard. This implies that connecting by NoMachine with an account having a blank password is not possible unless you configure your Windows to open the appropriate policy.”

    NoMachine offers the possibility to connect without a username and password in Guest Desktop Sharing mode. This requires a user to be present on the computer you are connecting to because the connection must be authorised. I’m not sure if this is of interest to you, but you can read more about it here: https://www.nomachine.com/guest-desktop-sharing.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.