Connecting Arch desktop to Arch laptop got 
Error 104

Forums / NoMachine for Linux / Connecting Arch desktop to Arch laptop got 
Error 104

Tagged: 

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #39898
    mcjev
    Participant

    Hello team,

    Got a laptop which I installed Arch Linux on it and installed NoMachine as well. I am connecting from ArchLinux Desktop trying to remote ArchLinux Laptop and getting error. Not sure what to do as it is working when I remote from ArchLinux Desktop to virtual desktop PopOS.

    I have attached the session log from my Arch Desktop client if that helps.

    Please help me how to solve as I’d like to use NoMachine only for all tasks. Also let me know if more info are needed for troubleshoot.

    Thanks in advance team!

     

    #39909
    shelter
    Participant

    Silly question maybe but is the NoMachine service started?

    #39911
    Britgirl
    Keymaster

    Hello, can you confirm which package you’ve installed? The tar.gz is the most appropriate for Arch Linux, and I would remove and install again just to make sure. We checked recently that NoMachine installs and works with Arch Linux, which it does.

    Please do the following, where “nomachine-current-installation-file.tar.gz” is the name of the package you installed.

    sudo /usr/NX/scripts/setup/nxserver --uninstall 
    sudo rm -r /usr/NX/ /etc/NX
    sudo tar zxf nomachine-current-installation-file.tar.gz -C /usr
    sudo /usr/NX/nxserver --install redhat

    Futher reference for Arch can be found here: https://kb.nomachine.com/AR03L00789

    #39921
    mcjev
    Participant

    @shelter, yes the service started. I can even remote from Arch Laptop to PopOSvirtual desktop no problem, but can’t remote from any computer to ArchLaptop.

     


    @Britgirl
    , I see, I got the installation from https://aur.archlinux.org/nomachine.git which came from AUR. Will try your recommendation and will report back results.

    Thanks all!

    #39933
    mcjev
    Participant

    Hello, so I have tried the recommendation and still not working.

    I found out that my ArchLaptop installation is using Wayland, I have switched to X11, rebooted and works.

    Observed that it is a bit laggy though as intermittently freezes for a couple of secs more or less. I can see my mouse moving on Arch Laptop but on my Archdesktop kind of freezing, seems like its waiting for sync?

    No problem connecting from ArchDesktop to PopVirtualDesktop. Feels like i’m actually on my Pop.

     

    Any recommendations or tweaks?

    #39941
    shelter
    Participant

    A bit laggy or very laggy?

    Perhaps it can’t find your screen. Is the lid closed on the laptop? Try connecting to the laptop with the screen active.

    #39945
    Britgirl
    Keymaster

    I understand that on X.org everything works fine but with Wayland it’s laggy. Could you follow the suggestions in this article?

    Connecting to a Wayland-based desktop running in a Linux virtual machine
    https://kb.nomachine.com/AR04R01083

    Look at the sections Option 1 “PipeWire desktop sharing provided by the desktop compositor” and Option 2″Use EGL capture”.

    Please also check our notes for recommendations and tips:

    Notes for connections to Linux physical desktops running Wayland
    https://kb.nomachine.com/AR02P00969

    #39954
    mcjev
    Participant

    Hi, I am connecting to my X based Arch now, before i was connecting to wayland based Arch which I got issues. I’m able to remote with my Arch Laptop no problem. Thanks for the help.

    #39956
    Britgirl
    Keymaster

    mcjev, thanks for letting us know.

    If you happen to switch back to Wayland and only if you want to, enable the logs on the server side and send them to us so we can check. This would help us understand what’s going on.

    See this article for instructions: https://www.nomachine.com/DT11R00182

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.