Connecting from Mac to Linux: how to fix the resolution

Forums / NoMachine for Linux / Connecting from Mac to Linux: how to fix the resolution

This topic contains 7 replies, has 3 voices, and was last updated by Avatar fra81 2 weeks, 6 days ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #23663
    Avatar
    emilianoheyns
    Participant

    Every time I log in to my remote Linux system, it sets the resolution to 1920 x 1080, which means I have to pan around the screen because the NX window on the Mac is smaller. I can set the resolution 1024 x 768 and that fixes it but I have to do that every time I connect.

    #23672
    Avatar
    fra81
    Moderator

    Hi,

    please check that the ‘Match the client resolution upon connecting’ box is unchecked in the NoMachine menu inside the session -> Display -> Change settings panel.

    #23673
    Avatar
    emilianoheyns
    Participant

    I don’t know where to find this. I don’t see it in “Edit Connection”, and once the session is opened I dont’ see a “Display” option in the menu.

    #23683
    Avatar
    Britgirl
    Keymaster

    You change it via the connection menu (enter the menu using Ctrl-Alt-0 or via the page peel). See the tutorial here: https://www.nomachine.com/changing-how-you-view-the-remote-host

    What version of NoMachine are you using on the client and server side?

    #23700
    Avatar
    emilianoheyns
    Participant

    Ah, thanks. A few things:

    • I don’t see anything resembling a “page peel” — nothing visual that stands out to me at least, but ctrl-alt-0 works.
    • “Match the client resolution upon connecting” is already checked, but maybe this is actually the problem — I have multiple screens, not all of the same resolution (and not always the same screens). But in any case, I want to just always connect with 1024 x 768, regardless of what my own system is connected to, or what display size it reports.

    On the client side I use 6.6.8 (macOS 10.14.6), on the server 6.8.1-3 (Ubuntu Linux 19.04)

    #23711
    Avatar
    Britgirl
    Keymaster

    As Fra suggested previously,

    please check that the ‘Match the client resolution upon connecting’ box is unchecked

     

    As for the page-peel, see our online guide here: https://www.nomachine.com/DT10K00060#2. It’s in the top-right corner.

    Maybe you missed the Welcome Screens when you first connected and then disabled them? You can re-enable them by following the instructions here: https://www.nomachine.com/AR11O00951

    #23720
    Avatar
    emilianoheyns
    Participant

    Jeez that’s dense of me, sorry.

    The page peel option is checked, I just don’t see it. Unchecking the “match resolution” works, I can reset the resolution to 1280×800 and it adjusts immediately, but if I disconnect and reconnect, the “match resolution” is still off, but the selected resolution always reset to 1920×1080. This happens even if I check “use custom resolution” and set 1280 x 800 — initially it will show 1280 x 800, but when I login, the screen resets to 1920 x 1080 (and this is reflected in the slider in the ctrl-alt-0 screen).

    #23744
    Avatar
    fra81
    Moderator

    when I login, the screen resets to 1920 x 1080

    Probably I didn’t get it right before. I thought “login” as “connect to the server”. Do you mean that you log in the remote user into its desktop, i.e. you connect to the login screen on the physical display and then log in?

    In that case, it is likely that the desktop environment stores the last resolution set and uses that when starting up. If you change the resolution via the system preferences inside the session, then the new resolution would be stored.

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.