Connecting to Manjaro Gnome

Forums / NoMachine Terminal Server Products / Connecting to Manjaro Gnome

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #28113
    Avatarriso
    Participant

    Hi,

    I am currently trying out NoMachine Workstation for Linux.
    I am trying to connect to Manjaro Gnome using virtual desktop. My machine has Gnome DE. And I am using nvidia gpu.

    When I try to connect to custom session I get Cannot run /etc/X11/Xsession default error.
    When I try to create new virtual desktop I get Session negotiation failed error.

    in node.cfg I have:

    DefaultDesktopCommand “/etc/gdm/Xsession ‘gnome-session –session=gnome'”
    AvailableSessionTypes unix-remote,unix-console,unix-default,unix-application,physical-desktop,shadow,unix-xsession-default,unix-gnome,windows,vnc

    grep ^Exec /usr/share/xsessions/gnome.desktop

    Exec=/usr/bin/gnome-session

    ls /usr/share/xsessions

    gnome-classic.desktop  gnome.desktop  gnome-xorg.desktop  remmina-gnome.desktop

    [log extracted & attached]

    #28140
    Avatarshiba
    Participant

    Hello,
    this is a known issue:

    Cannot start a virtual session on Arch Linux
    https://www.nomachine.com/TR10P08907

    Please use the ‘notify me’ checkbox to receive notification of when a patch has been officially released.

    As a workaround:

    1. Create a backup of nx PAM configuration (sudo cp -a /etc/pam.d/nx /etc/pam.d/nx.original). Then change /etc/pam.d/nx in this way:

    auth       include       system-login
    account    include       system-login
    password   include       system-login
    session    include       system-login

    2. Change DefaultDesktopCommand in /usr/NX/etc/node.cfg
    DefaultDesktopCommand "/etc/gdm/Xsession 'env DBUS_SESSION_BUS_ADDRESS=unix:path=/run/user/id -u/bus gnome-session'"

    3. Restart NoMachine:
    sudo /usr/NX/bin/nxserver --restart

    #28191
    Avatarriso
    Participant

    I have tried the workaround and the results are the same.

    #28250
    AvatarBritgirl
    Keymaster

    There was a mistake in the formatting of the command. Apologies. Try this and let us know if it helps:

    DefaultDesktopCommand "/etc/gdm/Xsession 'env DBUS_SESSION_BUS_ADDRESS=unix:path=/run/user/$(id -u)/bus gnome-session'"

     

    The only other option is to wait for the fix.

Viewing 4 posts - 1 through 4 (of 4 total)

This topic was marked as closed, you can't post.