Connecting to same old remote Linux VM fails after moving to a new laptop

Forums / NoMachine for Linux / Connecting to same old remote Linux VM fails after moving to a new laptop

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #36596
    svhansalias
    Participant

    Hi,

    I used to connect to a Linux VM from my laptop using NoMachine 5.3.12 client, with SSH protocol and username/password authentication. Recently I moved to a new laptop where I installed the same NoMachine version client and configured the client the same way as before on the old laptop to connect to the same Linux VM. However, when I try to connect, after I enter the username and password in the window that is presented, I get the “Ooops!” window with the message, “The NoMachine service is not available.”

    Following is the log (with certain info <truncated> for privacy):

    Info: Starting NoMachine version 5.3.12.
    Info: Loading settings from ‘C:\Users\rhansalia\.nx\config\player.cfg’.
    Info: Loaded translation files for ‘English’.
    9816 21180 09:46:30 540.549 Main: Exception handling library not loaded.
    9816 21180 09:46:30 540.549 Main: Creating the client session.
    9816 21180 09:46:30 540.549 ClientSession: Initializing session at 0x01add3c8.
    9816 21180 09:46:30 724.892 ClientSession: Initialized session at 0x01add3c8.
    9816 21180 09:46:30 730.197 Main: Entering the GUI event loop.
    Info: Slave server running with pid 9820.
    Info: Listening to slave connections on port 22376.
    9816 21180 09:46:35 465.265 ClientSession: Starting session at 0x01add3c8.
    9816 21180 09:46:35 465.265 ClientSession: Going to start session ‘C:\Users\rhansalia\<truncated>\NoMachine\My-New-Linux-VM.nxs’.
    9816 21180 09:46:35 479.885 Connection: Initializing connection at 0x0490d948.
    9816 21180 09:46:35 479.885 Connection: Initialized connection at 0x0490d948.
    9816 21180 09:46:35 479.885 Connection: Starting connection at 0x0490d948.
    9816 21180 09:46:35 479.885 DaemonSshConnector: Starting a new connection to host ‘10.198.136.243’ on port ’22’.
    9816 21180 09:46:35 479.885 Connection: Started connection at 0x0490d948.
    9816 21180 09:46:35 484.400 ClientSession: Started session at 0x01add3c8.
    Info: Connection to 10.198.136.243 port 22 started at 09:46:35 505.455.
    9816 13600 09:46:35 662.061 ClientSession: A valid certificate for this server was found.
    Info: Connection to 10.198.136.243 port 22 closed at 09:46:45 115.256.
    9816 21180 09:46:45 115.256 Connection: Connection at 0x0490d948 failed.
    9816 21180 09:46:45 115.256 ClientSession: Runnable at 0x0490d948 caused the session at 0x01add3c8 to fail.
    9816 21180 09:46:45 115.256 ClientSession: Failing reason is ‘The NoMachine service is not available’.
    9816 21180 09:46:45 125.205 ClientSession: Stopping session at 0x01add3c8.
    9816 21180 09:46:45 134.767 Connection: Stopping connection at 0x0490d948.
    9816 21180 09:46:45 134.767 DaemonSshConnector: Stopping the current connection.
    Info: Slave server running with pid 14200.
    Info: Listening to slave connections on port 64556.
    9816 21180 09:46:45 134.767 Connection: Stopped connection at 0x0490d948.
    9816 21180 09:46:45 144.998 ClientSession: Stopped session at 0x01add3c8.
    9816 21180 09:46:45 144.998 Connection: Stop reading because of parser request.

    I checked that the NoMachine server is running fine, and in fact, I am able to connect to the same remote Linux VM from my Macbook.

    Please help resolve this problem.

    Thanks

    #36626
    Britgirl
    Keymaster

    What NoMachine version is on the server side?

    #36654
    svhansalias
    Participant

    NX> 900 NXSERVER – Version 3.5.0-11

    #36661
    Britgirl
    Keymaster

    These forums do not handle issues concerning the legacy version NX 3.5.0. If you update to the latest versions both client and server side and continue to have the problem, please submit a new topic with the details.

Viewing 4 posts - 1 through 4 (of 4 total)

This topic was marked as solved, you can't post.